Trying to mirror a sword blade....then this happens.

I’m trying to make a model of Heimdall’s sword from Thor, and this keeps cropping up when I try to mirror it.

This is it in object mode, currently the mirrored half shows correctly.

Here it is again in edit mode, for some reason, the mirrored half isn’t showing and can’t be manipulated.

I’m stumped, and I have no clue how to fix this.

What happend is that you mirrored along the global X-axis. The mirrored part does not show up in edit mode because you have the “Use modifier while in edit mode” disabled (third button on the modifier).
When using the mirror modifier you are restraint to the x,y,z axis or a combination of those. What you want is mirroring along the sword axis (an edge in your model). I’m not sure how to achieve that.

You might have to make a duplicate and then use the mirror command and choose the correct axis for the operation. The mirror command will just flip your object without making a copy of it (at least the last time I used it). The mirror command is not the same as the modifier. You can type a search for it in the spacebar menu.

Make sure the little buttons here are clicked. They control if you see things in edit mode or not. Not sure what else would make it not show up.