Trying touse mapsmodelImporter addon, getting this error message

Python: Traceback (most recent call last):
File “C:\Users\M.Pirrie\AppData\Roaming\Blender Foundation\Blender\2.91\scripts\addons\MapsModelsImporter\operators.py”, line 54, in execute
importCapture(context, self.filepath, self.max_blocks, pref)
File “C:\Users\M.Pirrie\AppData\Roaming\Blender Foundation\Blender\2.91\scripts\addons\MapsModelsImporter\google_maps.py”, line 305, in importCapture
captureToFiles(context, filepath, prefix, max_blocks)
File “C:\Users\M.Pirrie\AppData\Roaming\Blender Foundation\Blender\2.91\scripts\addons\MapsModelsImporter\google_maps.py”, line 77, in captureToFiles
out = subprocess.check_output([python, SCRIPT_PATH, filepath, prefix, str(max_blocks)], stderr=subprocess.STDOUT)
File “C:\Program Files\Blender Foundation\Blender 2.91\2.91\python\lib\subprocess.py”, line 411, in check_output
**kwargs).stdout
File “C:\Program Files\Blender Foundation\Blender 2.91\2.91\python\lib\subprocess.py”, line 488, in run
with Popen(*popenargs, **kwargs) as process:
File “C:\Program Files\Blender Foundation\Blender 2.91\2.91\python\lib\subprocess.py”, line 800, in init
restore_signals, start_new_session)
File “C:\Program Files\Blender Foundation\Blender 2.91\2.91\python\lib\subprocess.py”, line 1207, in _execute_child
startupinfo)
OSError: [WinError 87] The parameter is incorrect

location: :-1

I got the same error. Then I noticed my antivirus had blocked the python scripts. Setting them trusted fixed the problem.

A lot people seem to be struggling with Google maps exports. The working combination for me is:

  • Blender 2.91
  • RenderDoc 1.10
  • MapsModelsImport 0.3.5.