Trying Ubuntu, i fail.

Hi there,
Ive just begun using Ubuntu, and i might say it gives me quite a lot of 'Wtf" moments…

Right now its day two, and i still can’t figure out how to run exacutables.
I’ve downloaded Blender 2.5 for linux 64bit.
Extracted it, and when i try to run the blender executable absolutely nothing happens, no error, nothing. Same for any other program which wasn’t installed…
Can someone explain?
I tried using the terminal, but it just says that the file “Blender” is not in that directory, which is another weird thing…
I tried to make a launcher, but that didn’t do anything either…

That sounds like you’re missing a dependancy…

An easy way to sort this is to install blender from the repositories…

I a terminal type:

sudo apt-get install blender

This will ask for a password and install blender 2.49

Or you could try running from a terminal… that way at least if it fails it’ll tell you why.

change directory to wherever you downloaded blender to:

cd /home/myname/myblenderfolder

then type

./blender

(that’s dot slash blender)

It’ll tell you what you’re missing!

I switched to ubuntu some months back and this one caught me by suprise. searchh the off topic forum to see the threads I have started several uses helped me out with instructions on getting blender to run in ubuntu.

That isn’t quite working…

Attachments


You’re missing openal

try

sudo apt-get install libopenal1

I also recently switched to Ubuntu and sometimes I also feel like: wtf?
I think you need to install libopenAL lib. To do so, go to System->Administration->Synaptic package manager. Then do quick search for libopenAL. Select it and apply updates. Ubuntu will do the rest for you.

Something else is missing.

Attachments


You can locate these files yourself by typing (for example)

apt-cache search libavdevice

that gives the following on my system

libavdevice-dev - development files for libavdevice
libavdevice52 - ffmpeg device handling library
libavdevice-extra-52 - ffmpeg device handling library
libavdevice-unstripped-52 - ffmpeg utility library - transitional package

because I have the medibuntu repositories…

libs ending in “dev” are for when you’re building things from source… the one you wa
t is

libavdevice52

install as usual:

sudo apt-get install libavdevice52

It finnaly works :slight_smile:

Download the official build from Blender Foundation (http://www.blender.org/dl/http://download.blender.org/release//Blender2.50alpha/blender-2.5-alpha2-linux-glibc27-x86_64.tar.bz2). You actually have a 64 bit installation I assume. Extract to your desktop (anywhere will do). Open folder, right click on Blender binary and change the properties to executable. Double click. I have only ever had dependency problems with unofficial builds from GraphicAll. This has always worked for me for many distributions over many years. Apparently this is to prevent execution of a downloaded executable, without the explicit permission from userland.

Hi flolks,

I’m having problems with blender in ubuntu 10.04. Actually it doesn’t work at all. Can’t launch it from Applications>Graphics>Blender, I click it and nothing happens. From Terminal ./blender results in “Segmentation fault”. I’m talking about a dual-boot system here (windows/ubuntu), and blender is working just fine in windows as it always did.

Tanks in advance.

Back to Windows

much easier to just install Blender 2.49 from Ubuntu software repositories. It just automatically installs all (or most) needed dependencies…

The most wtf I see from Linux n00bs is not understanding why it’s better to have a lib installed just once rather than the common Windows practice of getting a new copy of said lib with each zip package you get…

Get a graphicall build from Fish, he includes what you need. Seek the Fish.

yep get fish’s build

no other worked for me - bad part on Ubuntu usability

a package relying on external dependencies got nothing to do with Ubuntu or any OS usability at all. Fish’s builds work because he just includes pretty much everything needed, regardless if your system already got it or not. It’s the usual windows redundancy way, not highly regarded in *nix culture…

Personally I think Apple has the best idea, download an app, drag it to where you want it, double click it and it runs. don’t like it? drag it and the preference file to the trash and empty to uninstall. It’s nice that the official BF and Fish’s builds are packaged this way.

Thing is, the package manager is superior to this method because it keeps it updated, makes sure nothing conflicts. So yeah, use the package manager. MichealW has the right idea. If you absolutely need 2.5 do that. Otherwise, do like me, wait till 2.5 is in the repositories.

what i had to do to get blender working was just open my folder /usr/lib/ and see which file blender was missing by doing ./blender in the terminal, and since i knew everything was installed but blender just wanted an older version, i made links and renamed the libraries it needed, there were about 6 or 7 i think :stuck_out_tongue: it was a tedious process but it didnt take long and now it works just fine :slight_smile:

oh and welcome to ubuntu :smiley:

how is that any different in Linux?

BTW, will you blame Apple if some lamer creates a app with missing external dependencies that may not exist in your Mac?

name

u might think it is not ubunutu - but because of such things linux is not mass market ready

btw i also made the package manager look for missing dependencies downloaded them and
it still did not work

jay has has a point - apple is the only company that was able to make a linux distribution
usable for everybody.

not everybody wants or has the knowledge to deal with linux.
most just want to use a pc.