Turn off auto update of dynamics????

When you’re dealing with 400,000+ fluid particles, the LAST thing you want is for it to be trying to re bake while you scrub through frames. Is there any way to make it wait until I hit “bake” to update? I’m tired of waiting 2 minutes every time I try to adjust a keyframe or accidentally scrub through the timeline.

Figured it out, just go to the modifier in the stack and turn off the visibility.