Turn Off Middle Click On OSX?

Hi All,

I used a shared Mac at work and someone has turned on the switch between applications feature when you middle click. This effectively makes Blender viewport navigation unusable.

How do I turn off this unwanted feature on OSX?

NOTE: Expose and Spaces are turned off. I’m not sure what causes this…?


Look in User Preferences / Mission Control (depends on OSX version you are using)

Argh! They did it to me again.
Some new user has changed the middle mouse button on the Mac I typically work on.
This makes the Dock Task Bar appear when I press the middle mouse button, effectively making viewport operations in Blender 2.6.3 unusable on a Mac.

@Richard: As I re-read your suggestion, I am not sure where what you mean? Is Mission Control an OSX or Blender preference. I can’t find it in either place.

Have you tried the emulate 3 button mouse? It works by allowing you to press lmb+rmb to emulate the mmb.

I did try emulate 3 button mouse. The problem is that OSX is overriding all middle mouse actions before Blender can process them. I have my Spaces/Expose blank. I don’t even know what to call the thing that pops up. It looks like the Windows equivalent of ALT-TAB quick task switching.

Ah, I see, if I hold down ALT+LMB+RMB I get middle click, but no zoom. I use middle mouse zoom all the time. It is quite frustrating that the OS is blocking me from using my favorite program.


Mission Control is a preference pane in OSX 10.7 that does a similar thing to your screenshot. I assume you are using an older version of OSX as per my previous post.

What mouse are you using, it will most likely have its own preference pane (logitech and MS mice do) where you can customise its buttons, or in the Mouse preference or any other customising preference panes


I figured it out.
I plugged in the white mouse that comes with the mac and I get extra options in the Preferences for the mouse. This allowed me to turn off the Application Switching that was mapped to the Apple Middle mouse button.

When I have my Microsoft Mouse plugged into the USB port, those middle button mapping options do not appear in the Mouse dialog window.

So the solution is to plugin the original apple mouse, change the middle mouse button, then plug in your favorite mouse.


I’m having the same problem, but I’m using a newer mac with the “magic mouse.” When I plug it in the mouse only gives me options for swiping, tapping, etc.

(Edit) I know this is an old thread but any way someone can help?

Not using a magic mouse but I experienced the same issue when using my Logi MX master 2s on a mac. The solution was to download this button manager for the mouse: https://plentycom.jp/en/steermouse/

Open the manager in your preferences and select “Middle Button” It will say “Click” by default. Change this to “Application Switcher” Which is the default middle button function for a mac. Then change it back to “Click” Somehow this action removes the default “Application Switcher” function on the middle button on your mouse. You will now be able to use the middle button as intended.

This may be a solution. But this third party driver asks for money. I’d prefer a direct solution within the mac. I just need to disable the middle button for not showing all open applications/windows. I tried SteerMouse, but it didn’t install well and doesn’t open the options.

The thing is to disable the middle click button of the mouse to show the dock and open applications/windows so we can run blender better without happening that. So, no matter what kind of mouse we have, we have to disable from the System preferences. In my MasOs Catalina (10.15.7) there are mouse, keyboard and accesibility preferences, not some of other options that existed in the past…, but the solution is in Mission Control. So go to:

System preferences > Mission control
And in the lower part (fast functions of keyboard and mouse), disable the one where it is “Middle mouse button”.

That should solve it.