Turning off interpolation and anti-aliasing

I’m working on a project where I want the text on my textures to be blocky and not interpolated or anti-aliased. In the attachment, I’ve turned of sky rendering to highlight the issue and attached the result.

There shouldn’t be any white there, it should be a very solid green.
Any ideas how to fix this.

Attachments

codetest.blend (767 KB)

In the Texture panel, at the “Image Sampling” tab set the Filter to Area and the filter size to 0.1 (strangely it does not seem possible to disable it entirely), this should take care of the blurrying
http://i.imgur.com/YStdf.jpg

After that, either turn on Alpha in the “Influence” tab
http://i.imgur.com/T474d.jpg
or
Disable “Use Alpha”
http://i.imgur.com/HrqTC.jpg

This should take care of the white “thing” around the letters
And you should obtain :
http://i.imgur.com/LcaIk.jpg

Thanks, alpha influence and filtering did it.
The sky in the background is white, but I displayed the black one to show the negative effect.
I had to weak a bit to stop the edges from gaining a black outline, but I’ve got it working and it looks right now.

Thanks.