Twisted bones again...

Hi,

I tried to copy rotation from one armature of one bone to
another bone of another armature.

This fails horrible…

After realizing that the axis of two corresponding bones did not
match I tried to SHIFT-DKEY the first armature into a second one
and use the constraint “Copy Rotation” to the bones of the resulting
second armature with the corresponding bones of the first one as
targets.

This works fine (only) almost.

There were several bones still going wild when appliying the constraint,
the axis do match 100% this time, though.

What is going wrong here? Is this a bug in Blender or is the biggest
bug placed in front of my monitor ??? :wink:

Thanks a lot for any enlighment in advance !
Have a nice day!
mcc

So you’ve got a copy rotation constraint on a bone of one armature, and a bone on another armature. Right?

Have you got the local option of the bone on?
You could also get around these problems by adjusting the rotations of the bones, or as the bones are on different armatures, use IPO drivers.

Aligorith

Hi Aligorith,

thanks a lot for your reply ! :slight_smile:

Unfortunately I am not quite sure, whether I undertstand you right or fully
due to my still limited knowledge of blender and especially the Animation
thingy and due to the fact, that I am no native English speaker.

I SHIFT-DKEY an armature. Then I used a copy-rotation constarint on
Armature->bone.001 and as the target for it I used
Armature.001->bone.001, the corresponding bone of the other
armature.

“Local option” ? I dont know of such a feature, sorry…what is it? Where
is it ?

And “IPO dirvers” ??? I know of some very good Taxi drivers, but I fear,
that they are not part of blender ;O)

Sorry…but I see that I have a hole in my knowledge…

Keep hacking!
mcc

My first guess would be that you have IK on the bones (or connected bones) or some other constraint that’s preventing it behaving how you expect.

If not, can you post a blend file somewhere?

Hi AndyD,

thanks for your reply ! :slight_smile:

In the meantime I have found a way to prevent “the twisting bones”:
I found the “global”->“local” switch and setting it to “local” fixes it.

Unfortunately I cannot judge whether this is a fix or it is only
a fortunate coincidence of two sideeffects…

What is your judgement ?

Keep blendering on the bright side of the mesh!
mcc