Two issues with materials

I have Blender 2.61, and I’m going through Introducing Character Animation, 2.5 edition by Tony Mullen.

I’ve come across two issues that I cannot seem to find the solution to.

First: when applying the bump map and shininess to the eye brows, the map seems to work fine, but when I check the Intensity under Specular, everything but the eye brows become shiny. I’ve tried inverting and re uploading the bump map with no effect.

The results from checking normal under geometry seems to have the desired effect, although it could be inverted, I cannot tell.

The second issue is the eyelashes are casting a solid shadow. For those unfamiliar with the book I will explain how the eye lashes are made.

You duplicate the edge around the eye, then extrude them out to make two 2D planes in the shape of eye lashes. Then you assign a material to the lashes, and check the transparency and set the alpha to 0. finally after setting up a UV map you upload a transparent image with lines where the lashes are to be for the material’s texture. map it to UV, and check the alpha to 1 under Diffuse. oh and the book says to check “Receive Transparent” but I don’t see what deference that makes.

The first picture is with Intensity checked, the second is with it unchecked. the third is with both intensity and hardnes checked

Attachments




Regarding the specular map, it’s probably inverted. Either that, or Blender calculates it the other way around. In any case, set the specular intensity value to something lower than zero - ‘-0.5’ for instance.

The “solid shadow” issue is solved by activating “Recieve Transparent” in any material the shadow is being cast on.

Thank you. applying Receive Transparent on the skin texture worked for the eye lash shadow.

But Inverting the map just inverted the bump textures. it did not effect the shine in any way. changing it to a negative value just made it dimmer.

That’s strange, it should not affect the bump/normal value. Does the bump and specular map share the same textures or texture slot?

yes they do. same map, and same slot.

You might want to try using separate slots, one for the bump and the other for the specular. It shouldn’t make any difference really, but it’s worth trying.

EDIT: Feel free to upload your .blend. :slight_smile:

Here’s he blend file and the texture images, I hope it works.

Attachments

upload.zip (1.08 MB)

Ahh, yes. In the skin material, null the specular intensity while dragging the specular hardness to a value of ‘50’ or so. In the texture menu, make sure to activate specular Intensity and specular Color. The latter controls the overall effect, hence why it initially didn’t work. Good luck with your model!

Btw, next time you upload a blend-file, there’s an option to pack the textures into the file - File>External Data>Pack into blend :wink:

Thank you So much!