Ubuntu 12.04

I already installed the beta days ago but I had problems some libraries were not available for the new version.

Today I downloaded the new 12.04 version but will wait one day so all the programs I use that are not from Ubuntu repositories get updated so I hope I will not experience problems.

So tomorrow will be a day of installing it and talking here the changes I do to the default installation.

Post here all you want if you are already enjoying/suffering it. I myself continue astonished some people is using Gnome3 or Unity. Gnome3 even doesn’t have minimize button. Is just unbeliable how out of the real world their programmers are. I heard the explanation is “because you don’t minimize in Gnome3, you move apps to other desktops instead”. Give me a break!, that is a lot of mouse work compared to just minimize (or rolling up the window as I use: I double click on the window upper bar and it rolls up, is my favourite way instead of minimizing. But this option of course you only have using Cinnamon. We will talk about more later…

I dont understand, you can use programs for previous versions on new versions.

I use Blender, Chromium, Gimp, Ninja-IDE PPAs from the 11 on the 12 version…
Its OK because dependency is always >= of any version of system library

Except when you go to Synaptic and what you want is not there!. That was my problem (unrar I think) and then with last update before final release the Update program just collapsed and didn’t wanted to download anything, it said something about some library he was unable to find. Something about python I think it was.

Well, problems, problems…

I downloaded the iso thursday, and created an USB to install from it.
It didn’t installed.

So today, saturday I downloaded again the iso and I could see the size in bytes was exactly the same. But then I did a MD5 checksum and the result was different. So the iso I downloaded today is different from two days ago.

I created an USB disk with this new ISO (using Startup Disk Creator that comes with ubuntu) and no problem. I am just now writing this from Ubuntu 12.04.

I said no problem? Wait a minute…
First thing I always do in Ubuntu is install synaptic.

And now there is no synaptic anymore in ubuntu:

sudo apt-get install synaptic

and you get:

Package synaptic is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package ‘synaptic’ has no installation candidate

But in the beta I was using synaptic. So now if Blender needs some library not currently installed (libspnav, libopenexr,…) how the hell can I install them now in ubuntu?

Really, ubuntu is going in a way that makes all the users just crazy.
I hope this lack of synaptic is just something they forgot. Because if it is for people to use only the Ubuntu Software Center, I just will leave ubuntu and go linuxmint debian based.

I will wait some days (and also ranted in ubuntuforums, obviously I will have my second warning and probably banned (or was it three warnings to get banned?)). But how in the hell they want you to not go mad with such stupidities with each version. For example Gnome3 doesn’t have minimize button and it is called a feature so instead minimizing you “move windows to new desktops”. Imagine a developper with four apps open and say him to “move windows” instead minimizing…

Well, seems the problem with synaptic was only I thinking that was a new “feature”.

Synaptic continues there, the problem I had was that I just installed ubuntu and tried the terminal without refreshing the repositories. I tried Ubuntu Software Center to install synaptic and first thing it did was to download the repositories listing of software available and then download synaptic.

So the correct would be:

sudo apt-get update
to refresh the listing of the repositories
and then install synaptic.

Working fine 12.04
With the beta I couldn’t install some things but with the final release seem solved, and I was able to run blender without problem, just installing some libraries.

Even cinnamon seems to work a little better too there.
To install Cinnamon desktop:

sudo add-apt-repository ppa:gwendal-lebihan-dev/cinnamon-stable
sudo apt-get update
sudo apt-get install cinnamon

I still am busy downloading, my internets is very, very slow, Ubuntu Studio 12.04 LTS. Unity has been dropped for LXDE, low latency kernel (why would this speed up my renders as claimed?) and Jack are configured as default. Will let you know if it was worth my while, I find setting up audio software arcane and difficult as my knowledge in the audio field is sparse at best but I do need a working Rosegarden and installed plugin/soft synths without having to spend hours and hours on the forums before everything works together properly.

I never tried LXDE. I was to try that but I think I didn’t find how to install it and looking for I was on the Cinnamon page and installed that instead and now I totally Cinnamon fan.

At the moment my ubuntu 12.04 is just the base install + Cinnamon (instructions above in post 6). In some days I will go to 12.04 fully and post here all the programs I install, and perhaps someone can point me to an updated version with a different ppa (like gimp case where ubuntu repositories are yet with the 2.6 version !!!).

I’m current downloading it. Let’s see how it go…

I’ve added some (default) torrents of Ubuntu studio and Ubuntu, and started seeding to help you speed up the downloads, hope it helps :slight_smile:

Well because lack of an updated gimp I was using yet 11.10. But now I installed the new gimp 2.8 with the instructions in omgubuntu.co.uk:

sudo add-apt-repository ppa:otto-kesselgulasch/gimp (that smile is “:” and “o” but forum does that)
sudo apt-get update && sudo apt-get install gimp gimp-help-en gimp-data-extras
It says that what you are going to download can break your system. So first I did a backup of the partition using Acronis (but I really want to try CloneZilla and I will post here if I like it more than Acronis.
Acronis is doing the “iPhonization” too. In previous versions it would show your hard disks and then you click in the one you want to backup and next window shows the partitions and you choose the one you want to backup and then you select a name for it and the location in another hard disk you want it to be wrote. But in last versions it is not so easy anymore, now is like the app does what it wants, where it wants and it doesn’t give info. So I am getting done with Acronis and wanting to leave completely and go for an app that gives me total control again. CloneZilla can be.

Well after doing the backup of the partition where ubuntu 12.04 is, I installed gimp2.8 and works flawlessly in ubuntu 12.04. I plan now to install QtCreator and I think I will switch completely to 12.04 then (obviously without deleting the 11.10 partition for some months just in case.
In 11.10 I was using a special repository too for gimp and in an update it broke the system completely and was not able to even install the default gimp 2.6. So, lesson learned, before doing an update to these apps that are not from the ubuntu software center, I will do a backup of the system. Having a backup saved me of that bad upgrade and I could bring back from the backup a working gimp2.74. Then simply deactivated the ppa in the software sources and keep my working gimp 2.74 without updating.

I am using Cinnamon and I have it configured in a way that when I double click the upper bar of a window it rolls up. This is extemely powerful with gimp. Take a look to this images with the brushes panel rolled up and rolled down. I think in Unity this is impossible, and it was one of the multiple reasons I left for Cinnamon. I currently have Unity, Gnome3 (the two come with ubuntu) and Cinnamon. But I am using Cinnamon all the time.

To the left with the brushes panel extended and to the right with it rolled up. The panels are slightly below the window with the image so I can access to the window close/minimize/maximize buttons. These panels are kept always above the image window, even while rolled up.
http://desmond.imageshack.us/Himg515/scaled.php?server=515&filename=gimpb.jpg&res=landing

Compiling blender in 12.04 seems broken. So I am back to 11.10 I think…

What are the errors ?

You can try http://redobackup.org its better for unexperienced people, because its more friendly, and point-n-click.

“Compiling is broken” is too abstract… :stuck_out_tongue:

  1. I compiled and all perfect, then I tried to create a zip file (to upload to some ftp) and it failed to create the zip. I tried compiling every folder and the problem was in the python directory. It breaks some links to files. So I created the links (I do all this compiling with a script) and then it compiled and fixed the broken python directory and compressed in a glorious zip. Then I opened that blender and tried some scenes and I had several failures: segfaults anc crash in one ocasion, render but without textures in other.

  2. I compiled but without copying the python folder (the option is WITH_PYTHON_INSTALL OFF or something like that) and what happens? Blender doesn’t compile at all now. That was an incredible surprise. I even deleted the /build folder so I tried absolutely all.

So after around 2 or 3 hours I decided better go back to 11.10 and only go to 12.04 when the compiling be solved.
Also when installing gimp2.8 it said that perhaps it would break the system, so perhaps my problems is because gimp2.8 changed some library.

It stops when compiling elbeem. But I need to bring back from the backup ubuntu12.04 (backup before installing gimp2.8) and see if the “default ubuntu” compiles blender. I am thinking perhaps gimp changed something in the system.

I find Blender compiles fine here on 12.04, though I get a bunch of ‘undefined reference’ messages related to libimageIO. I can’t figure out what the actual error is though. Builds fine with Cycles set to off.

I built Gimp a while ago, on 10.11 I think, and it did break my system. I was careful to quarantine everything in Opt, but I still found parts of the system trying to use the newer libs it didn’t support. It made a bit of a mess, though it was reasonably straightforward to fix once the compiled support libs had been removed. I’ll never build Gimp again…

Well, “building fine” and “Cycles set to off” is incompatible for me. I need build with Cycles.

I thought people would be bored talking of installations and such but I think I am going to post what I am doing so anyone can try, and perhaps solve the problems.

I recovered my “fresh just installed ubuntu” from the backup to try again today. This backup was done before installing anything so it is like I just installed ubuntu,

Now to compile blender I am doing and writing here the steps:

  1. INSTALLING ALL THE PROGRAMS AND LIBRARIES BLENDER NEEDS TO COMPILE:
sudo apt-get install g++ cmake subversion git build-essential gettext \
 libxi-dev libsndfile1-dev libpng12-dev libfftw3-dev libopenexr-dev libopenjpeg-dev \
 libopenal-dev libalut-dev libvorbis-dev libglu1-mesa-dev libsdl1.2-dev libfreetype6-dev \
 libtiff4-dev libsamplerate0-dev libavdevice-dev libavformat-dev libavutil-dev \
 libavcodec-dev libjack-dev libswscale-dev libx264-dev libmp3lame-dev libspnav-dev
  1. The above were things from the blender wiki. But more is needed that they forgot to say:
sudo apt-get install cmake-curses-gui scons yasm freeglut3-dev libboost-all-dev \
libjpeg62-dev libtheora-dev libfaac-dev libfaad-dev libglew1.6-dev

And here comes “first trouble”. When installing the libjpeg62-dev I see the system says that it is incompatible with “libjpeg-turbo8-dev” so it uninstalls this. Now imagine some other software needs this one and I am fu**ed, for example trying to compile gimp myself and it needs it. This is the “DLL Hell” and we have here in Linux a “DLL Hell v2.0”. For me is much worst than in Windows. And I don’t understand why Linux programmers are not resolving this nightmare. It creates that you install gimp2.8 and it can break completely ubuntu (you are warned when installing). The solution is absolutely simple: every library must have a unique name and links to “short names” must be not permitted by the system (these “short names” were born to fix this nightmare but in my opinion the developper that thought this “great idea” is stupid because it created exactly the “DLL Hell” (different libraries versions have the same name). And I see version after version nobody in Linux world is even preocupied! Give me a break!

After a healthy rant I continue:
Now is time to download the source (I just copy the folder from ubuntu11.10 with all the source code of blender trunk). And now I enter in that folder and:

  1. svn up
    To update the source code there. And the terminal answers me el muy cabron:
    svn: OPTIONS of ‘https://svn.blender.org/svnroot/bf-blender/trunk/blender’: Certificate verification error: signed using insecure algorithm (https://svn.blender.org)

So they “updated” svn to make our lives a little more difficult. Well, here is google to do the contrary: and the answer in google is:
Open the file /(your home folder)/.subversion/servers and add on the bottom of it:
ssl-trust-default-ca = no

And now after “svn up” a message asks me if I want to add this exception, I answer “p” (for permanently so it doesn’t ask ever again this stupid question).
Now blender source is updated to last version.

  1. boost, ffmpeg, oiio need to be downloaded. I just copy the /lib/linux64 folder from ubuntu11.10 and place it here. (if someone wants some exact detail of anything I wrote just ask). Using this boost instead the one we installed in step 2) would avoid probably the installation there (libboost-all-dev). But I have all these steps wrote in a text file and I am just doing it without checking any “easier” way that would be using the one in the system that probably matches this one. But then Sergey updates this library and your code would not compile, so better do it this way.

  2. CUDA compiler: I just launch a nautilus with administrator power:
    gksudo nautilus
    and go to ubuntu11.10 disk and copy the cuda folder /usr/local/cuda
    to /usr/local in ubuntu 12.04
    Now it will find the cuda compiler and will be able to create the .cubin executables that are loaded in the GPU card when you uses GPU

  3. Where /blender folder and /lib (boost, ffmpeg, oiio) folder is I create a /build folder. Enter in it and:

cmake ../blender -DWITH_CYCLES=ON -DWITH_CYCLES_CUDA_BINARIES=ON -DCUDA_BUILD_CUBIN=ON -DCUDA_BUILD_EMULATION=OFF -DCYCLES_CUDA_BINARIES_ARCH="sm_10;sm_11;sm_12;sm_13;sm_20;sm_21" -DOPENIMAGEIO_LIBRARY=../lib/linux64/oiio/lib/libOpenImageIO.a -DOPENIMAGEIO_INCLUDE_DIR=../lib/linux64/oiio/include -DBoost_INCLUDE_DIR=../lib/linux64/boost/include -DBoost_LIBRARY_DIRS=../lib/linux64/boost/lib -DWITH_FFTW3=ON -DWITH_CODEC_SNDFILE=ON -DWITH_CODEC_FFMPEG=ON -DFFMPEG=../lib/linux64/ffmpeg -DFFMPEG_LIBRARIES="avformat;avcodec;avutil;avdevice;swscale;orc-0.4;dirac_encoder;mp3lame;schroedinger-1.0;theora;vpx;x264;xvidcore;faad;ogg;vorbis;vorbisenc"

(look all these paths to the /lib/linux64 that you must fix in case you have the folder in a different place)

It creates a lot of files inside /build