ubuntu 8.10 - Nvidia problems

Hey there,

I have been trying to get my nvidia driver to work on ubuntu 8.10 for the past couple of weeks

I have only been able to get the generic driver to work - which has no 3d acceleration (making the screen lag a lot in the 3d window and box select does not work)

Has anyone got their nvidia drivers to work with the new ubuntu

My Card: Nvidia Quadro FX 5400

I can’t get it to load any nvidia driver at all
I have tried though synaptic and also by stopping X and running the nvidia installer

ever time I try - it fails to load and I’m stuck in “low graphics mode”
the only way to get it back to hi-res is remove the drivers and use the generic driver

any stories of success will give me hope

cheers

from the release notes:

nVidia “legacy” video support

The 71 and 96 series of proprietary nVidia drivers, as provided by the nvidia-glx-legacy and nvidia-glx packages in Ubuntu 8.04 LTS, are not compatible with the X.Org included in Ubuntu 8.10. Users with the nVidia TNT, TNT2, TNT Ultra, GeForce, GeForce2, GeForce3, and GeForce4 chipsets are affected and will be transitioned on upgrade to the free nv driver instead. This driver does not support 3D acceleration.
Users of other nVidia chipsets that are supported by the 173 or 177 driver series will be transitioned to the nvidia-glx-173 or nvidia-glx-177 package instead. However, unlike drivers 96 and 71, drivers 173 and 177 are only compatible with CPUs that support SSE (e.g. Intel Pentium III, AMD Athlon XP or higher). Systems with older CPUs will also be transitioned to the nv driver on upgrade.

It doesn’t mention Quadro…

What about the cpu bit? does yours support SSE?
How are you installing the drivers? through the restricted driver manager? Which drivers are you activating?

thanks Michael,

I did see that - but I think my card is still meant to be the 177 driver (I’m pretty sure that’s what I was using in 8.04)

my CPU:
AMD Athelon 64 processor 3200+ - which supports SSE

So in theory it should work…I think??

This is how I have tried to install the drivers:

  1. via synaptic - tried glx-96, glx-173 and glx-177
    then tried to activate the driver with the restricted driver manager

  2. tried stopping x - and using the nvidia installer from their website - for 177.80 and 177.82
    this build the driver for the current kernal

I know the nvidia driver worked 100% with 7.04 and 7.10
I am only 70% sure that it worked with 8.04 - I know it was listed in the restricted drivers but I can’t remember if I ever tried to activate it with that release.

So I guess the first step is to find out 100% that the hardware is compatible

I have installed nvidia 8800GTX driver under ubuntu 8.10 successfully with no trouble, maybe quadro is not supported with nvidia driver,
try unoffical solution I am sure there are non official drivers out there…

good luck

Ok,

So how do you install a driver on Ubuntu?

I am a Windows guy, and on windows there are programs called “installers” that install drivers for you, but on Ubuntu, no such thing exists.

Say I download some files from nVidia and nVidia claims they are drivers for Ubuntu, what next?

How do I activate them?

if the file is something like NVIDIA-Linux-x86-177.82-pkg.run.sh

here is what you do

go to tty1 (Ctrl+Alt+F1) - this look slike a full screen terminal

then you need to stop the desktop display


sudo /etc/init.d/gdm stop

then install the driver
navigate to where you put the file

eg cd Desktop or wherever

then you start the installer


sudo sh NVIDIA*

(the * wild card saves you from typing the rest of the filename)

then follow the prompts
and restart the desktop manager


sudo /etc/init.d/gdm start

then press Ctrl+Alt+F7 to take you back to you desktop
the driver should already be active (I think - mine never works)
but also check in System>Administration>Hardware Drivers

if you need to revert
you will need to go to tty1 and stop Desktop again
and then


sudo NV* --uninstall

(* wild card saves you typing)
hope that sorts you out

you can also try to download glx-177 from synaptic and then activate in the Hardware drivers

but none of these methods work for me

Hey, Waylow, you are fast. Two replies while I was looking for information.

http://www.nvidia.com/object/linux_display_amd64_173.14.05.html
http://ubuntuguide.org/wiki/Ubuntu:Intrepid#Installation_of_ATI_and_nVidia_Graphics_drivers

I have done it quite a lot recently
(everytime there is a new kernel or update related to my problems)

In case anybody is having the same problem
I didn’t fix it but I did manage to roll back to an older kernel where everything is working

I am using 22.6.22-14

I have given up with 8.10 ubuntu
I will try again in a few weeks or so

[QUOTE=;][/QUOTE]
Download Driver From HereDownload New Drivers For Free

[QUOTE=;][/QUOTE]
Download Driver From Here

Download New Drivers For Free