Ubuntu - Grub Error 21 !!!

I just installed Ubuntu 5.10 on my computer. I have WinXP on my Master drive, and Linux on my Slave Drive ( both drives are on the same cable btw ) And on the first reboot I got a blank screen saying this:

GRUB Loading stage1.5.

GRUB loading, please wait…
Error 21

Thats it. It then locks up. Right now, I’m using the live cd and I can’t really do much.

What should I do!?

I did a google search but all I found out was that it seems to be a common problem and some people fixed it by changing some sorta config file (?)
I dunno what it all means. I only got the CDs today.

Please help.

Grub is the bootloader, so if properly configured it can let you choose to boot windows or linux or two versions of windows and three versions of linux each with two kernels and from the floppy drive…

but you probably want it set up with two options:

well anway, the grub config file [everything in linux is in a config file somewhere, no evil registry] is at /boot/grub/menu.lst , you should be able to edit it, and perhaps run grub [if you’re booting off the live cd you might have to chroot before doing this]

it should be fairly straight forward, but I’m not one good at explaining such things at such a low level. Google is very useful [try “grub howto”, or “grub error 21”]

5 secs of googlin’ for the solution gave this.

If you need help for anything, Ubuntu has a wonderful community, just give a look.
Very helpful as you begin!

You were pretty certain to get some kind of grub error. All you need is a LiveCD like Knoppix and use that to mount your /boot partition and change the Grub file grub.conf in the grub directory. Google will allow you to find what you’ve done wrong.

Be aware that Grub uses the order that your BIOS arranges harddrives, not your OS. Enter the bios and write down the boot order of the hard disks (ignore optical drives etc…).

First drive in boot order is hd0 not hd1.


Thanks. I figuered it out. My second drive was set to NONE. So i ended up setting it to AUTO along with the master. Works fine now. yay.