ubuntu has no taskbars when blender is open

Ok. My Windows Vista just got hit with the System Security Rogue virus and I decided to chunk any and all software related to Microsoft and go with Ubuntu. I currently have Ubuntu 8.04 and I have the latest Blender, 2.49a.

My problem is that when I open Blender it works flawlessly, but there are no taskbars at the top or bottom of my screen, so I can not switch applications, like to answer an IM, or to check the time or anything else outside of Blender. The only way I can get out of Blender is to totally shut it down.

How can I fix this problem?

run it in window mode.

From wherever you launch blender, right click on it and go to properties. In the commands box type blender -w.
it should work i guess…

Even when Blender is in fullscreen mode, you ought to be able to change windows with an Alt Tab, an Alt D (default for show desktop), or by switching to another workspace (if you have configured hot keys for it).

Thanks for the replies. I fixed the problem just last night. For some reason my Alt-Tab combo was shut off. I turned it on and it works. Just a minor glitch remains where when I Tab out, Blender stays glued to my desktop, but I can minimize it now that I have the taskbars back. Thankies much.

That isn’t really a glitch, but the behavior for bringing windows above fullscreen windows. without the -w flag Blender is set to take over your entire screen. If you downloaded from the repos or getdeb you can launch it with the “blender (windowed)” option for these things to not happen.

Ctrl alt side arrows should flip between workspaces, I usually run Blender in its own dedicated workspace fullscreen.

I once took blender in windowed mode and stretched it across three workspaces. :stuck_out_tongue:

This must be because of compiz, some window manager problem, blender has run in a window by default for over 2 years.