Ugly artifacts in the render with RayMirror on

Hi,
in desperation I decided to look for help here because the last hour I’ve been trying to figure this out:

When I render my scene with a light in it and Ray Mirror enabled, I get these ugly circular and wavy artifacts and I just can’t get rid of them no matter which setting I alter. Is it about the material? Or is the light source set up inappropriately?

Please see attachment for details.

Thanks in advance for any hint that could help.

Attachments


I’m sorry but I don’t see what you are talking about other than the image compression artifacts in the background - is that what you mean? If so then try saving the file totally uncompressed or in something like tiff. If you think its from the lights then you may have some luck playing with the light’s sample number or the material’s sample number. BTW this is also sometimes a problem with the background material if it is an imported image.

One quick fix is to render with alpha and composite over a colored background

Try with this:

Attachments


appears to be your geometry… try the dither or change the geometry

I was also getting that ugly banding in my renders too for a while. The info on here helped me out. I adjusted the Bias setting under the Shadow buffer. http://blender.active-domains.com/x/x13487.html

Forgot to add, play with “ClipSta” and "ClipEnd like noted on the site, it eliminated my banding problems.

Thank you everyone for your time and advice.

It just doesn’t make sense - these artifacts simply shouldn’t be there with Blender’s default settings - never seen such ugly effects on any scene rendered from Blender. Could it be I changed some default render setting by mistake? Perhaps that’s the most reasonable explanation…

@walshlg:
The issue here were indeed those distractive circles/waves visible in the background of the render but they surely can’t have been caused by compression, since I’ve tried multiple file formats, including *.png, *.tif as well as pure *.bmp (no compression at all on that one, afaik). Finally, there was no image imported whatsoever, only pure RGB colors with some specularity applied onto the objects.

@DarkAltar:
Thanks for the link. However, turning the BIAS setting on/off or changing the SBIAS/LBIAS setting doesn’t seem to be affecting the render in any way whatsoever in my case. And neither did ClipStart/End as advised in the article, even with only 1 frame.

@B65ISP:
So far, this has been actually the only working solution, although I’m far from being sure it’s the “right” one. It does remove the ugly lines between transitions from brighter areas to darker areas (more/less light) but one can notice the “dithering” effect or diffusion of the pixels in the image slightly. And those artifacts only disappear after the last pass while they’re still visible throughout the whole rendering process, which is quite odd.

Now I’m wondering what the default Blender value for the “Dither” option is because I doubt it is actually “2” (as long as I didn’t reset it by mistake).
So, this method might just work but I still don’t think it explains how this can possibly be happening in such a plain scene and with default settings - I assume that’s not regular behavior in Blender.

Tomorrow, I’m gonna do a fresh Blender install on sister’s computer and see what happens there…

Thanks again for your help and support.
:slight_smile:

Hi,

As far as I know, it’s not a bug, and the only solutions I can think of are to increase the dithering (as B65ISP said) or to save the image in a format like OpenEXR that supports HDR.

If you examine the colours in the image you will find that the bands only differ from each other by the minimum amount supported by a 24/32 bit image (e.g. the colour of one band might be 59, 59, 59; and the colour of the neighbouring band might be 60, 60, 60). Your eyes are sensitive enough to notice this change. The only way to avoid it is to mix the bands up by increasing dithering, or by increasing the colour space by using an image format like OpenEXR (and displaying it on a high quality monitor).

Oh my, I can’t believe the explanation is so simple… You’re so right !

Didn’t think about that but when checked, the difference really is only one unit at each of the transitions. Therefore, the solution then really is diffusing the pixels around that area more rapidly to fake the real-life smoothness of color transitions. Does really everyone working in Blender have to crank up the dither value to get smooth renders…?

Still, I can hardly believe this “transition problem” has worried me in graphics in general only on account of my sensitive eyes. I mean, you guys can all see it clearly in there, right? The ugly edges… I may be insane but they really are all over the place there ! :smiley:

Allow me to thank you all once again by sharing this beauty I’m listening to right now with you:

http://mythematica.com/audio/Mythematica_-Vitam_Vas(radioedit).mp3

(100% legal download)

:slight_smile:

Oh my, I can’t believe the explanation is so simple… You’re so right !

Didn’t think about that but when checked, the difference really is only one unit at each of the transitions. Therefore, the solution then really is diffusing the pixels around that area more rapidly to fake the real-life smoothness of color transitions. Does really everyone working in Blender have to crank up the dither value to get smooth renders…?

Still, I can hardly believe this “transition problem” has worried me in graphics in general only on account of my sensitive eyes. I mean, you guys can all see it clearly in there, right? The ugly edges… I may be insane but they really are all over the place there ! :smiley:

Allow me to thank you all once again by sharing this beauty I’m listening to right now with you:

http://mythematica.com/audio/Mythematica_-Vitam_Vas(radioedit).mp3

(completely legal to download)

:slight_smile:

Heureka!

  1. My yesterday’s reply seems to be still held back by a filter, hope it’s released soon. Therefore I’ll reply only shortly now.

  2. @rawpigeon: Thanks for the hint, you were indeed right.

  3. The source of my problem finally revealed:

Extreme “stretching” (diffusion/whatever) of light reflection on the surface of my material caused by the HARDNESS value turned down very rapidly along with Specularity value turned to minimum. I made the material harder and the ugly circles are gone. See…?

It has nothing to do with RayMirror after all - wish I could change the name of this thread.

Hopefully someone else can benefit from this finding in the future.

:yes:

Attachments


Crap. I just noticed the artifacts are back with RayMirror on. Even with high hardness.

Never mind. I’m using the DITHER option now to get rid of them.

:confused:

Oh god I get those… I`ll try both solutions. just for the record, the default dither settings 0.000

OK, thanks for the info. I also temporarily removed those by disabling the outer sphere the light was bouncing off in my scene and instead only using world color settings / Ambient Occlusion.