Ugly mesh, recalculate normals does nothing

I’ve been working on a model of a truck that will eventually be used in Source games, principally garry’s mod. It’s come along quite nicely, but it seems everywhere there is a triangle…it looks…crimped? Maybe that isn’t the right word, but creased? There are no doubles, the mesh is totally smooth, and I’m not really sure why it’s happening…it would be basically impossible to do something that complicated without triangles.

We need the blend file or at least some screenshots to help you.

There’s one such example…the mesh is perfectly smooth there.

Attachments


It looks to me like the normals are being pulled because of the amount of edges connected to the vertex at that corner. Smooth shading doesn’t truly make the model smooth and will sometimes give bad results. It doesn’t look like you are using a sub surf mod and I wouldn’t imagine that you would considering it will be used in a game. The only solution that I currently have is to use edge loops but that increases poly count and since you are using this for a game that wouldn’t be a good option. Sorry I wasn’t of much help but I don’t really have experience with low poly models.

Just try this:
Tab (go in the editmode) -> a (select all) -> ctrl + n (recaluclate normals)

That should work, i hope for you xD

I don’t think this is a problem with normals. It looks mire like a problem with smooth shading and poor topology.

You are using smooth shading over sharp corners, which causes those darker areas. I’m also guessing that the model consists of many narrow triangles which also cause similar problems. Usually you would want to keep your faces as close to squares as reasonably possible, or if you have long and narrow faces, try to put them in flat, isolated areas.

A good idea is to select the edges that are sharp on your model, then press CTRL+E -> Mark Sharp
Then in Object Mode, add an Edge Split modifier, and untick the “From Edge Angle” setting of it, so only the edges you manually marked as sharp will become sharp while you’re in smooth mode.

That usually help in those situation, by example a cylinder when displayed in smooth mode :
http://i.imgur.com/Dw5Vi.jpg

If i mark as sharp the actual edges that should be sharp and add an Edge Split modifier with only the “marked as sharp” setting enabled :
http://i.imgur.com/0JYgq.jpg
A bit like smoothing groups are working on other applications.

Totally agree with sanctuary. When making lowpoly models you should use sharp edges a lot anyway.

Wow thank you so much. I made those edges sharp and that took care of things. Thanks again that’s going to make a huge difference