UI: Acceleration towards a mesh

When I am examining my objects in blender’s main window, I notice that as I get closer to an object, the zoom in gets slower. Sometimes it would be useful to tour inside my objects without slowing the zoom rate exponentially. Is there any way to turn that off?

press . in the numpad while a vertice sor object selected…you will be able to scroll and zoom more to that object

Turn off perspective view (numpad 5) and the zoom will be easier to control.

If you want to flitter about inside of things, I suggest shift-F fly mode.

Otherwise, I just use num period to zoom current about once a minute, and c and shift c occasionally tho those are about the cursor and the area as a whole.