Unable to append models


(Yukari) #1

I have tried to append objects from other files, but then nothing shows up. This still happens even when I am in object mode.


(Alan Talbor) #2

Have you placed your 3D-cursor in the center? Do they appear in the outliner?


(Yukari) #3

Yes, I made sure my cursor is in the center but either nothing will show up in the outliner, or it will show up but the mesh will be invisible.


(Zak Gre) #4

Note that by default object appended from the library is placed in the target scene on the same 3D layer where it was in the original scene so check the Outliner or enable all 3D layers with ~ (tilda) to look up for the object. It’s possible to override that behaviour by enabling Active Layer in the Append settings (shown in the bottom left corner of the File Browser editor when you append) and object will be appended on one of the 3D layers active in the target scene.

Also it’s not clear what does it mean “mesh is invisible”; if object appeared in the target scene then append was successful and hidden object can always be unhidden.
One thing to mention as well is that object preserves properties for being hidden in viewport or from rendering when appending; so if it was hidden in resource scene it will be in the target scene too.


(Yukari) #5

I don’t use layers, and the mesh just doesn’t appear at all.


(Peter18) #6

Have you dried pressing ‘full stop’ on your number pad? It brings whatevers selected into view. I’ve had a bug in 2.8 where things sometimes go invisible, but pressing . normally fixes it.


(Yukari) #7

What if it doesn’t show up in the outliner?


(Peter18) #8

It would have to be in the outliner. What version of Blender are you using?


(Yukari) #9

I’m using version 2.79


(Peter18) #10

If it does show up in the outliner, then you can try the thing I mentioned above, or you could try and snap selected to 3d curser. If it’s there, one of those should find it. Also, make sure your in oprtho view (5 on num pad). The model could just be massive, and being clipped.

Also, are you appending objects from other .blends, or are you trying to append external files? (Not sure if they’ll even show up actually…but I’ll ask anyway) Could try opening the .blends of the thing your trying to append to make sure it’s not corrupt, or to double check there are no issues with it.


(Yukari) #11

I’m appending from other blend files and I made sure I was in orthohographic view. I’ve also tried appending different meshes from different files to test them, but it just doesn’t work.


(Peter18) #12

When you append, are you appending object, or are you appending mesh? Because mesh won’t work.

Something else to try. Open the .Blend of the thing you want to append. Add the object(s) to a group and name it something memorable (APPEND_ObjectName - is a good way to go) Save the .blend.

Now, go back and try and append it, but this time, select group, and then find the group you just created, and append that.


(Yukari) #13

Oh, I see, I was appending meshes instead of objects. Thank you for your help! :slight_smile:


(Peter18) #14

Not a problem. Happy to help! :slight_smile: