Unable to apply modifiers to object. "Applying modifiers failed for [object]"

So I made a character in Blender

I tried to apply the mirror modifier in Object Mode but just keep getting the failed error

I have no clue why it’s failing. As a new user, I can’t attach the .blend project.

Pls help!

OK I solved it, seems this “key” was preventing the modifiers from being applied. Not sure why. Deleting it from the object allowed applying modifiers

I think it’s impossible to apply modifiers to an object with Shapekeys (it normally just says exactly that in error message, though).
You either have to plan ahead and apply the mods before creating shapekeys, or look into transferring the keys from temporary copy.

1 Like

That “key” component was shapekeys?

From first screenshot it seems you had a “Mouth open” key…

1 Like

Yes that’s correct. Right so I think that deleting the key component deleted that shapekey. That’s fine I can always remake the shapekey, I had created vertex groups for it so it shouldn’t be much of a problem recreating the key