Unable to apply texture in UV mode


I exported below avatar(.fbx) from Marvelous Designer and the tshirt texture was in .sbsar format


@blender, In UV mode am unable to apply the texture to the tshirt. pls suggest


So i guess you need the substance painter addon ??
Or choose another export possibility ?? (Maybe not using substance painter materials if you can’t use them ?)

What’s UV mode ?? If you want to apply some material to some faces then you have to select them in edit mode and go to the material properties, select and assign it… :person_shrugging:

Thanks @Okidoki

Using substance painter addon apply to apply the texture.
But while exporting the avatar as glb/fbx unable to export the applied materials
Screenshot while exporting avatar

The exported glb file

Pls suggest if i missing something

AFAIK glb has limited possibilities according materials because it wasn’t made for a high definition workflow (?) … so why are you switching ? Most of the posts according to Marvelous Designer here on BA use FBX as far as i remember… (maybe search for this?? top right… magnifier icon ??? )

We need to render this avatar from babylonJs Hardly there is any option to access the .fbx file from web. People are suggesting to convert fbx to glb to render from Babylonjs.

am exploring other options to access from BabylonJS

Is it set to “export”?

  1. avatar(.fbx) from Marvelous Designer
  2. avatar from babylonJs Hardly there is any option to access the .fbx file
  3. People are suggesting to

So you aren’t telling the whole story…


…am i wasting my time… ?

Gentleman, just to give u insight

@ marvelous designer selected the avatar and texture(.sbsar) and exported as fbx
@blender converted .fbx to glb
@blender trying to render with .glb

somehow at step 2 unable to export the texture materials into glb

I dont know what made u feel that i am wasting yur time. Parallely am exploring other ways
Maybe there is some delay while responding from my side…

Right now am trying to apply the texture in UV mode and check…

You import into blender from fbx and then export to glb and then again import as glb and then render…

I can’t help you.

1 Like

Just adding the image into the UV space does not add it to the Material file…you have to associate the texture, ( which you showed you do have as a PNG file) in the Material editor also!

BTW you are also showing us the Solid View which will also not show textures…set it to material preview or rendered view.