unable to arrange objects according to gravity

Hello!

I want to arrange 9 coffee capsules in a glass, so that they set themselves in the most “physically correct” (because of gravity) way, without penetration (neither into the glass’ walls nor into one another), and without empty spaces that make them look like “floating” in the air.

To do so, I put my 9 capsules on top of the glass, chose BLENDER GAME, set them as RIGID BODY, and left them falling into the glass, running the animation recording it (in order to save the last frame, when they are in equilibrium after falling). No way, the result is inacceptable. See the attached image to see what I got.

I tried to change:

  • Collision bounds checkbox
  • Radius (in teh Physics/attributes panel)
  • damping etc…

But I always finish with either a penetration into the glass, or with some space between the capsules.

Maybe I’m wrong (indeed I am a newbie for what concerns Blender Physics), but I tend to think that there should be is an “absolute” setting, all the others (where you finish with penetration or free space) aren’t physically correct…

Can somebody suggest me how to obtain the “physically acceptable” solution, with all capsules in equilibrium laying one over the others, and no penetration between the meshes?

Thank you in advance for your patience.

Attachments


For a start use a more suitable collision type. Your object is not a box so set something like Triangle Mesh for complex shapes
Before you do anything always reset the objects scale (Ctrl+A)
To be more helpful, its always best to attach your blend file rather than relying on a single screenshot.

Thank you Richard (wow, wonderful Toy Room in your site!).

I tried with triangle mesh, unsuccessfully. I attach both the blend file and an additional screenshot to show you what I get if I use the triangle mesh.

Thanks for helping!

P.S.: (edit) Some better results with “convex hull”, but still not precise…

Attachments

nespresso2.blend (1.64 MB)


I’ve attached a quick setup. Adding more physics substeps from 1 to 2 also helps. I’m sure you can tweak it better.

Attachments

nespresso2a.blend (654 KB)


Tweak it better? It’s just perfect! It’s what I needed. Thank you!
Sorry for the dumb question: what are the physics substeps from 1 to 2?
I have already understood a lot, and my setup is much better compared to 4 hours ago. But still not like your one…
I saw that you changed the shape of the glass, making it “volumeless”. Is it one of the reason of your result?

Thanks once more.

Okay - found the “physics substeps” parameter (in World -> Physics). I’m going to play with it to check out if it improves even further…

I saw that you changed the shape of the glass, making it “volumeless”. Is it one of the reason of your result?
Just to make the simulation as simple as possible. The original object is on layer 1 which you could use for any rendering. Adding more substeps will slow down any simulations. Just changing to 2 should be enough, increasing any further just slows everything down with little or no additional benefits

Okay! I got it. Thank you very much for your help.