Unable to assign light group

Here’s my problem, hope someone can help.
I have 2 sun lights in a scene. One light is set to have ray traced shadows and the second light has ray traced shadows disabled. I have made the second light (with shadows disabled) a light group so I can assign it to a single material in the scene. I have assigned the light group to the material (that I want to be affected only by the light group) using the GR: field in the shader tab of the material panel and have also enabled the exclusive button. when I render, the material that was to have been lit only by the light group is also casting ray traced shadows. I have scanned through the forum to see if I am using the light group properly and it appears I am.
Placing the object and its intended light on a separate layer and using the layer option in the light panel is not an option here.
Any suggestions on what I am doing wrong or have missed in my setup would be appreciated. I am using version 2.46

You may need to render the shadowless object from a separate scene because buffer shadows and raytracing are created in a separate preprocess before the rest of the scene. This means that shadows will still be cast by objects if a shadow casting light is in the scene. Alternatively you may disable the Tracable or Shadbuf buttons for the shadowless object on the Links and Pipeline tab in the materials buttons.