Unable to export Lightwave Pointcache MDD on 2.8

Hi guys!

I think I may have found a bug today.

Working on a project today I tried to export Lightwave Pointcache MDD for a mesh. I received the error messages that you see in the pictures I attached.

At first I thought this was just an issue that was specific to my project but that is not the case.

I installed the latest version of Blender 2.8 and the issue persists on it as well. I also tried creating a new project with nothing on it except that default cube and the issue happens there also.

I have tested this issue on 3 different computers, one being a Mac using the latest OS X, the other two being a desktop and a laptop both using Windows 10 with all updates installed. The issue is happening on all 3 computers.

So is Lightwave Pointcache MDD simply bugged on the current version of 2.8? Is there a workaround?

Is there any additional specific information that I can provide that might help?

Thanks guys.

2

Bump… Anyone?

Yeah, the plugin probably needs updating. It looks like it’s not compatible with the last rounds of API changes. I’ll go bug it.

Created: https://developer.blender.org/T65973

It’s now fixed. The fix should be in tonight’s build in 12 hours or so.

Dear god you guys are great!

Thnx so much!

I traansitioned to blender form 3ds max abut two months ago. Any time I had to contact autodesk support, the experience was nightmarish. You guys are a pleasure cruise compared to them.

Thnx again.

2 Likes

Does anyone know if its normal that the origin of the mesh gets set to world. Thus by using this exporter the origin is set to (0,0,0) instead of its prior origin.

I looked at the pc2 exporter and this has the option to use local or global. So i added this and it works perfect.
I was testing out MMD cache so i could use animation from 2.80 in bl 2.79 I noticed the mesh would be object in 2.79 would get double offset from world (0,0,0). you can reset the location ofcourse, but i dont want to do that. Thats why i added " use local or world". Is this usefull for others?

Again,
Light wave MDD export is not working in 2.9.1

mdd