Unable to see metaballs I have appended


I am an absolute newbie in Blender, I usually use 2D tools like Gimp or Inskcape. So, I apologize if this is a stupid question. I also apologize for my possible English mistakes, as a non native English speaker.

So, here is my problem : I can’t manage to append metaballs correctly from one blender file to another. Or, more precisely, when I am in my projet, I go to File > Append, choose my .blend file and my objects to append, and in the 3D view, I can only see the mesh objects. All my metaballs are somehow hidden (though none of the “hidden” menu seems to change that). I can only see their outline. But they appear correctly in the render view… It is then difficult to modify the shapes, because I can only do modifications blindly, and render to see what I have done…

I have tried the “show hidden menu”, tried to change their material, no effect. I imagine maybe there is a tick somewhere I didn’t check ? I’ve search a lot on Google but I didn’t find anything.

Also, I tried to recreate the metaballs I could not append (add > metaball > ball). But, even if I am not in edit mode, and with nothing selected, it seems that all the metaballs I add are linked : I cannot delete one without deleting all metaballs in my project, and they are created with the same material as the already existing metaball, and it seems I cannot change that. I have found that metaballs are linked if the blender user add a ball with one ball already selected, or in “edit” mode. But there must be another parameter ?

I’m using version 2.69 (default package in my Fedora).

Thanks a lot for you help !

More than anything else, the actual .blend(s) would be great. Are you sure you’re appending and not linking the objects to another scene? Have you tried grouping the metaballs in the original .blend (Select then Ctrl+G) then appending the group?