Unbearable Lag

Problem:

Blender is so laggy lately. I can hardly model, even adding a circle or anything lags blender up. Often times it will freeze up chrome and every other application also, particularly so while in render preview.

Details:

GTX 1070
AMD FX 8350 + Cooler
16GB DDR3 1866
120GB SSD
1TB 7200 HDD
Windows 10
Blender 2.77

Hi, start Blender with “–factory-startup”, you can add it to desktop shortcut or start Blender from command shell (cmd).
This start Blender with default settings, disable all addons and so forth.
Check out https://builder.blender.org/download/ for latest daily build, these also support GTX 10x0 cards for Cycles render engine.
Make sure you have original driver from Nvidia not from Windows update, there are different and sometimes crippled.

Cheers, mib