Undocumented Feature: 'Autodestruct Model'

I ran upon this one again and again and again whilst trying to parent a bunch of objects to an armature: pressing the ‘P’ key whilst in object mode spontaneously crashes the program (it becomes unresponsive) and ruins the model. (the pieces fall apart) Better hope you saved… Any fixes for that? Also, is there any way to move a group of objects en masse from one file to another while keeping parenting and constraints?

have you tried another version?

[particularly a build from cvs, avalilble from the testing thread on blender.org]

No, I hadn’t. But this is supposedly the ‘official’ build, so I’m thinking that you might want to work on that in the next release. I think that it’s starting up the ‘play’ mode except that there isn’t anything to play, but that doesn’t change the fact that it completely locks up and displaces of all parented objects. I can just be wary of it for now, but that’s something that probably needs to be fixed.

Is it reproductible ?
If yes, post at blender.org, not here, in the bug tracker with a minimal .blend showing the error.

Here, it is the artists site, coders not necessary frequent it.

“P” to parent an object to another ? To me it’s “Ctrl+P”.
P is used to activate the game engine… this is why the program may seems to be “unresponsive”. Just press the “escape” key after you pressed the P key, and I think everything will be responsive again.

Don’t I wish it weren’t reproducible. But yes, everytime I hit the ‘P’ key, it happens. I also found a bug whereby an IPO curve point cannot be moved more than a distance of 100 frames at a time. I need to start making a running list of these to report them. Anyway, thanks for the input. I created the topic mostly as a vent for frustration, I guess. After you’ve had a model ‘autodestructed’ about four times, it gets incredibly annoying…

ctrl P to parent. P to start the game in the game engine.
<edit> are you sure they disappeared? maybe they just fell off the screen?

(btw, I know it’s Ctrl + P to parent, but if you’re parenting 20+ items to an armature in the same fashion, it’s easy to make a mistake and hit P alone somewhere down the line.) And yeah, escape did FINALLY make it revert, but I had to wait upwards of a minute before I could. (You can’t blame me for assuming it was unresponsive after 30 seconds of hour-glass-cursor and not responding at all)

as long as there is no way of user-hotkey-configuration you should remember not to press “P” alone during editing of heavy scenes :slight_smile:

abt. your second question: in a new file, use the command “Append” from the file menu to browse existing .blend files (much like exploring directories). click right to select what ever you want to import (objects, armatures, lights etc…). be careful with meshes - they are getting imported but need to be “used” by an object, or you won’t see them in the viewport. so better go and import objects, all linked data (meshes, materials etc.) goes with them, too.

OS and specs?