Unexpected emit results and a strange white outline on object's edge in my composite

I am experimenting with compositing right now. In my regular Blender render, you can see how the light blue gems are emitting a bluish light onto the gray skin of my character. This glowing effect is what I am aiming for.


But on the composite render, the emit on my gem material is not shedding light on to the gray skin and the gems are almost saturated to pure white. Also notice how the bottom curved edge of the head is carrying a thin whitish line which looks rather unnatural.


So my questions are:

  • How come the light is not being shed onto the skin by the gem’s emit in this composite?
  • How come the gems are almost saturate bright white?
  • How come there is a light white line on the bottom edge of the character’s head in the composite?

I setup my nodes to emulate the way the Blender Renderer renders scenes to the best of my knowledge.
Here is an image of my node setup

If you want the emit to cast light onto your object you’ll need to enable Indirect Lighting in the World settings.

You need to exclude the emit pass from the combined pass via the little camera icon to the right of the pass name on the render layer properties pane. The highlights are blown out because you added the pass basck to the composite without doing the afore mentioned exclusion. Left click dragging over these highlights in their current, undesirable state (over the composite window) will likely yield values greater than 1.0 (at the bottom of the composite window) showing this analysis to be accurate. If not then post a screen shot of your composite nodes set-up.

The unusually bright edge on the head of the model may because of the multiple Add nodes you’re using. At value 1.0 for both, some edge pixels may be adding up more than expected, causing them to become too bright. Drop some Viewer nodes in at the intermediate stages to track where the edge starts to show up, then adjust accordingly. It may require some masking to eliminate.

Also, I guess I’m a little puzzled why you use all those nodes to try to imitate what the full render looks like, when the Render Layers node’s Image output pipe has all that data already. The passes are most often used to isolate certain render pass channels for further processing, rather than to recombine them all into a full render without using Image.

BTW, if you want the gems to illuminate the model’s skin, why not simply attach some low-energy, small-distance Lamps to them? There are many options for modulating & isolating the Lamps’ lighting effects, more so than what using Indirect Lighting or the Compositor will probably give.