Unhidden geometry is always auto-selected

For years it’s been this way in Blender : when one unhides geometry, it is automatically selected. I never understood the logic of that. And so far I never once found it useful, on the contrary.

Is there a way, in Edit or Object Mode, to unhide geometry without it being selected ?

It’s simple: the geometry you want to hide is selected before hiding it… and this selected status is perceived… IDK if it’s possible/workintensive (in the sources) to deselect the geometry while hiding…

Meanwhile you can only make a tmp vertex group adding (assign) your selection (inverse selection and remove after repeated use), unhide, select none and select the tmp vertex group… (maybe someone can make a quick addon about this… then even delete the tmp-named v-group??)

Yep- when you unhide, there’s an option dialog that appears in the bottom left corner. There’s a checkbox for “Select”. Turn it off, and there you go :slight_smile:

1 Like

Oh no… :person_facepalming: i have to look more at those context dialogs… learnt again something new…

1 Like

Much better solution to this :
Edit > Preferences > Keymap Untick all the “Select”.

This way when ones unhides any geometry, it won’t be selected anymore.