Unknown Crashing Issues

Hey, I hope I’m in the right place because I’m extremely new and I hope this is the proper area to post this in, anyways.

About half a week ago, I tried to open blender 2.81 and it immediately crashed (as soon as the command prompt opens, it crashes a frame later.) I did some research and I figured out various ways to check what was happening. I used the debug tools and it has consistently come back with the same error, see below. (This is from when I downgraded to 2.80, but the log is the exact same)

Switching to fully guarded memory allocator.
Blender 2.80 (sub 75)
Build: 2019-07-29 09:44 AM Windows 
argv[0] = blender
argv[1] = --debug
argv[2] = --debug-gpu
argv[3] = --python-expr
argv[4] = import bpy; bpy.ops.wm.sysinfo(filepath=r'C:\Users\i3-7350K\AppData\Local\Temp\blender\debug_logs\blender_system_info.txt')
read file 
  Version 280 sub 39 date unknown hash unknown
Error   : EXCEPTION_ACCESS_VIOLATION
Address : 0x0000000000000000

It’s strange because the address is all 0’s, which to my knowledge nobody else has experienced. It’s extremely frustrating because I have not been able to find someone with a similar problem to me, so I came here.

The issue seems to have arose from me installing new ram, I removed the old stick and replaced it with two new ones, and to my knowledge blender would not open after that. It could also be me updating to windows pro, but I don’t see why that would screw it up.

My Specs:
Windows 10 Pro 64-bit

CPU
Intel Core i3 7350K @ 4.20GHz

RAM
16.0gb RAM

Motherboard
ASUSTek COMPUTER INC. Z170M-PLUS

GPU’s
4095MB NVIDIA Geforce GTX 1050ti
Intel HD Graphics 630

Here’s what I’ve tried:
Reinstalling blender, (both msi and .zip versions)
Downgrading
Swapping RAM
Updating Drivers
Manually installing opengl32.dll into the blender folder

It’s very odd that this happened out of the blue, there were no updates and 2.81 was running fine, even with outdated drivers.
If anyone could provide help, that would be appreciated, thanks.

Hi,

I am not sure what is causing the issue but is there a reason to not use 2.83.3?

Could be a bug from the older versions of blender. Otherwise I would try to boot in safe mode and/or then run the blender .zip from a separate USB Drive or portable drive.

I tried both of those, but it doesn’t seem to work. Still the same error, upgraded and downgraded in safe mode and on other drives.

Hmmm… this is a tricky problem to diagnose without access to the hardware. Have you/ are you able to wipe the boot/install drive and then re-install blender?

I suspect there are some files or corruption happening on the actual boot drive and searching and finding all relevant files is time consuming.

FOLLOW AT OWN RISK! SAVE/BACKUP FILES
During the windows install when it asks to pick a drive to install too make sure to delete all partitions and then re-format and install. It is by far the easiest way to wipe all partitions from a boot drive.

Regards,
Peter Steel

Unfortunately I cannot completely wipe the boot drives and re-install blender, it’s just too difficult to do especially because I have certain files I cannot back up and need to keep, sorry.

Is there another solution you have in mind?

My only other idea would be to install blender on a separate partition or drive with all install files going to that drive and not the C drive. You would have to manually change where blender installs to that drive/folder so when you run blender it only runs off of the separated drive.

I’ve tried this on upgraded and downgraded versions of blender, no dice.

I’ve done some research and I’m 90% sure that blender isn’t recognizing the amount of physical memory that I have installed, but the problem is I have no idea how I would edit the value that recognizes the amount of physical ram installed.

I just wanted to try to revive this thread again.
I’ve tried switching to my previous ram and using old settings, I’ve tried deleting the userpref blend file, and it’s still not working.
It won’t work even if I install it on other drives, I’m not sure what went wrong because even the address of the error is not recognized.
Anyone have any other advice?

After a seemingly unimaginably large amount of time I’ve been able to fix the issue, sort of?
The most recent thing I did was copy opengl32.dll into the directory of blender, and now it will open. Recently, before that, I got plenty of errors that were different but this time it said that I needed OpenGL 3.3, which I know I had but for some reason I had to copy the new one and update my drivers a few dozen times. Anyways, Blender runs incredibly slowly and there are drawing errors? I’m not sure how to explain it but here is a photo.


Again, any help would be appreciated now that the error is more common.

Edit:
Okay it is the next day. I looked more into OpenGL32.dll and apparently you’re not supposed to use it because it puts all the stress on the cpu which is odd. Anyways, after removing it I get the same error as before (Need OpenGL 3.3 to open) but it’s odd because my graphics card supports 4.4? All of my drivers are updated and it won’t work.
Any help is appreciated.

Do you have the monitor cable connected to the motherboard or to the nvidia card?
Can you share GPU-Z screenshots about those GPUs?

GTX 1050ti is widely supported by Blender 2.8+, so you should be able to work with it just by having correctly installed nvidia drivers.

The intel one is integrated, and the NVIDIA one is not.

I have 2 monitors, and they are both plugged into the motherboard.
Thank you for the reply.

Any reason the monitors are not connected to nvidia card? intel iGPU is very weak compared to GTX card.
I think that in Windows for nvidia card to work by default, the screen has to be connected to nvidia card. Then if you want some power save mode with intel iGPU or you want iGPU to take over, you should be able to configure this from the nvidia control panel (but always with the monitors cable connected to nvidia card).

1 Like

Ah, so it appears that connecting my main display to the gpu will make it work. Thank you.
Not too sure how GPU’s worked, but didn’t know it worked like that.
It runs smoothly now, no idea why it decided to start screwing up and cause this issue to begin with.
Thank you for solving it.

I guess I will just have to switch over my monitors whenever I wish to use blender? I can live with that.
Thanks again.

I’m not sure what your goal is. Ideally, both monitors/displays should be connected to the nVidia card. If you can’t connect both monitors to nvidia card because you don’t have enough connectors available on nvidia card, I think that secondary monitor could be connected to motherboard and then configure things from nvidia control panel. But I am not sure about how to configure this in Windows (I am a Linux user)

Yeah, there are enough ports available but I have to use a whole mess of adaptors and extender cables which is not ideal.

One of the adapters is slightly defective in that it lowers the brightness of the monitor so I can’t see very well on it, and that adapter is the only way I can be able to connect my main monitor to the card. So, using that adapter means that my main monitor will be darker than it should be which makes it difficult to work especially with photos and videos.