Unkown CUDA error

I’m new to this forum, and I’m not sure if I’m posting this in the right place… but I’m having a little trouble with with my real-time rendering in cycles with the GPU.
I’ve got the Alienware m17x laptop, with a GTX-580m GPU and an intel i7-2670QM CPU.
When I try switching from material mode to rendered, I get this:
I’m using the official 2.62 from blender.org, but I’ve also tried different builds, with the same result. I’ve also tried updating the GPU drivers, but still cannot get it to work.
Can someone please give me some advice. This has been annoying me for the longest time.

Hi marmstrong,

This is currently caused by Blender (even with GTX 580m selected in user preferences) trying to use the default Sandybridge Intel graphics GPU for real time viewport rendering.

The way to get around this is to close Blender. Right click on your desktop and select ‘NVIDIA Control Panel’

In the window that opens, make sure ‘Manage 3D settings’ is selected on the left.
On the right hand side you will see two tabs, ‘Global Settings’ and ‘Program Settings’, click on ‘Program Settings’

Click the ‘Add’ button and in the new window locate Blender’s folder and click on Blender.exe.

Once that is selected you will be taken back to the previous window, here you can now select to use the Intel card for Blender’s interface (Default), or select the GTX 580m. Select the 580 and click ‘Apply’

Now when you start Blender you will be able to use real time viewport rendering plus, while not rendering the display will be much smoother.

The only downside of doing the above, while doing a full final F12 render Blender’s interface will become very sluggish and almost unusable.

Hope this helps,


Thank you so, SOOOOO much!!! This worked perfectly!! I’m so happy :slight_smile:
I really appreciate it,

You’re welcome Mark, pleased I was able to help. :slight_smile:

In my haste to reply I forgot to welcome you to BlenderArtists, also noticed I made a few dyslexic typos please ignore those. :o

Do you know about ticking VBOs (below Anistropic Filtering) in Blender’s user preferences System tab, ? Doing so will help further improve UI interaction when handling complex geometry, more so in Object Mode.


Oh ok, I’ll tick it and see if there’s a difference. Thanks, though :slight_smile:

I´m using a dedicated GTX GPU (not connected to a monitor) and then I´m not allowed to open the Nvidia control panel. Guess I´ll have to switch for while and change this later.

Thanks for sharing a possible solution though. :slight_smile:

I have a situation similar to Jan-Sandahl. I’m using an Nvidia Tesla card. Because it only has one monitor connection, I’m using a different card for dual monitors. I am able to use said Nvidia card for GPU rendering on F12, but the realtime view does not work. Also, I’m not able to open the Nvidia control panel because there are no monitors that are using the Nvidia card.

Is there a way to use the realtime view even though a monitor is not directly connected to the GPU?

i have simlar prob

but even selecting GPU (via NVIDIA control panel AND in Blender user preferance system tab)
Cycles viewport render won’t work with GPU