Unnecessary visualization of pressed Shift,Ctrl and Alt ( Windows Ink )

Need help plz. Every time I rotate or move something in the viewport, blender shows the pressed shift, ctrl or alt. This only happens when I use the stylus on a tablet with windows ink enabled.

I can’t use wintab because in the latest versions of blender there is a bug (or not a bug) With wintab enabled, when I raise the stylus from the tablet to a distance, the pop up menu disappears, and can’t control view with numpad.

Thanks in advance

Wecome :tada:,
i’m not aware of that blender do this. The old key-pressed addon isn’t included in blender anymore… i suspect windows ink is doing this ? Are there any settings for this (at least not in blender; only Input → Tablet Max Threshold/Softness and nothing about showing anything…).

Yes, this happens when you select “windows ink” in the settings. I looked in the Windows settings, stylus settings, but found nothing. In the software of the tablet itself, I also did not find anything. With “windows ink” there have always been problems even in photoshop, and the same thing here. I would use “wintab” but starting with a certain version of blender, there are problems that I described above.
You can certainly work, but all this is very distracting :slight_smile:

To clearify:
This is a Windows problem… (i’m on linux). Funny thing: this is from 2016: Answers MS: How do I turn off the little CTRL、SHIFT、ALT bubble that pops up ?

Microsoft has not solved this problem to date. I haven’t come across this before since I used wintab. But Blender did not fix the problem with wintab that I described. In short, it’s complete crap.

Has you said: MS the maker of wintab didn’t fix it. So why should Blender fix a problem made by wintab ? :question:

Because in earlier versions everything worked. Problems started with version 2.9. MS does not fix the problem with win ink, and its not the same problem. Wintab they did not touch, he remained as he was. Problem with wintab its blender problem that start with version 2.9 https://developer.blender.org/T92787

It doesn’t matter if earlier versions of blender worked… it is a problem of win ink so why does have the blender devs have to fix this… M$ is making millions… I’m done here.

1 Like

I’m sorry dude, but you don’t understand what I’m talking about. If you don’t understand, it’s better to remain silent. I never said that blender should fix the “windows ink” error ( you are a Linux user, have you ever drawn or sculpted from a tablet on windows? ) Windows has two drivers for drawing from a tablet: 1) wintab ( old but stable ) 2) windows ink ( new one ) In blender versions 2.8 and below, tablet ran on “wintab” and had no errors. Starting from version 2.9, this bug was present (the link I left above), but now it has been fixed on 2.9. But starting from version 3.0, it appeared again, it is also in version 3.1. I don’t care who does what. I am not a programmer but an artist and 3d modeler. If it is possible to do as before, please be so kind (what I had in mind). I created this thread to find out what the problem was and if it can be solved? But as we understand the problem of shift, ctrl, alt bubbles ( windows ink ) in windows 10, MS did not fix it. Along the way in Windows 11, they solved the problem. How can I close this topic? is it possible ?

Okay after getting a heart/like and PM it seems to be that i’m not completly out here :wink: .

So if i don’t use windows i don’t understand that showing the status of shift or ctrl in the middle of the screen isn’t a major flaw made by MS reported on the official answer.microsoft (which was answered with a typical: try to remove non-MS stuff and reboot ) already six years ago which doesn’t have to do with blender.

And you link of blender.developer says it all:

This is a driver specific issue (not locally reproducible).

Even further deep in the rabbit hole:

The issue was reintroduced when Wintab high frequency was re-enabled.

But you aren’t asking for help rather complaining about the fact that the blender devs even seems to solved this problem (and it 's not what they get paid for) in one version but the newer one shows that this is very weird bug (from MS).

And why you are assuming that i didn’t ever draw or sculpted with my wacom tablet ? :question:

You are explaining that:

But you pay for the Windows-OS (the hardware would be cheaper if not bundled with) which makes this awful display of shift/ctrl in the middle of the screen. And only in the last post of you there are the first question marks.
You didn’t say: Blender should fix this. But what’s this :question: :

This is a blender forum and not a Windows-Answer forum which even doesn’t give an appropriate answer:

Method 1: start you PC in safe mode…
Methos 2: Try clean boot…

After you explains the purpose of your post (because you assume someone isn’t smart enough to understand this already??) and use your first questions mark…
Again: if blender seems to play fine with this MS-bug that doesn’t matter and isn’t the job of the blender developers…
And then you even say:

I may not be an native english speaker but your english is confusing… Who are they now? Microsoft or Blender? And if this is fixed then why:

Blender can’t fix your Windows-System. (It also seem to be no other windows users are interessted in this topic.)

What was this after several window-updates some users couldn’t print anymore or even use their computer at all (black screen at startup) .

The blender community is very helpful. But sorry…
And now my big cup of coffee is empty…

1 Like