Unreal Static Mesh Export - 1.1 UPDATE

Hello Guys.
I’ve updated my Exporter Script for Unreal Static Meshes to Version 1.1. This is for all who want’s to use Blender-Meshes in Unreal Engine Games. It supports the following Features now:

* ASE File Format

  • as many Textures as You want
  • Smooth Groups
  • Vertex Colors
  • Object Scale and Rotation

In addition to this, the Script helps You to find possible Errors in Your Object by checking it. The Scale-Factor in the Defaults has gone. Instead, You can adjust if the Object Scale and/ore it’s Rotation shall be applied on Export.

http://www.project-blender.onlinehome.de/USM.jpg

You can find the Script, including a Demo File on my WebPage.
The Tut is located here in the Tutorial Section: blend.polis
(German only, but easy to understand)

It works with 2.33a and higher. (Tested on Win and Linux.) Python installation is not necessary.
Thanks, Doc

STUNNING!
export worked good for me, didn’t try imprting to ut

the interface is soo gui! I love it
english docs would be a bluss but it’s soo easy to use.

Thak’s for the positive Comment, Steve. I had a lot of Fun while making the GUI. :smiley: Yo say it, it’s totally easy. So an english Version is not strongly necessary.

trying the script, it said the mesh was valid, so i clicked export

i got this error(i renamed the file py file)

Traceback (most recent call last):
File “unreal_ase_export_1.1”, line 781, in bevent
File “unreal_ase_export_1.1”, line 527, in Export
ValueError: unpack list of wrong size

any help would be GREATLY appreciated. I’m really happy i found this script. just wanna get it workin :slight_smile:

-pandora

It crashes blender when I run the script :open_mouth:

Hello Guys. Sorry for my late Answer. I dislike to see that some People have Problems with my Script. I’ve testet it with (Win) Blender 2.32 and above. I’ve exportet Tons of Meshes to UED3.0 without any Problems.

So, what Blender-Version do You use?
And which OS do You have?

I’m currently working on a 2.33a Update with a couple new Funktions. It would be great if You can help me to find and fix these Bugs, that the new Version works proper.
Thanks, Doc

I’m using OSX. When I tried it last I was using ether 2.32 or 2.33 don’t remember. But I’m on 2.33a now.

And it crashes the whole Blender? Do You get any Errors if this happens? Maybe in the Dos-Box?

Hmmm I seem to have lost the script.dd And couldn’t find it on your web page. Could you possibly send the link over here?

Just the Script 1.0 is available here.
The whole Demo-File is on my WebPage. (Klick on the Header over the Image.) Sorry, but my WebServer do not allow direct downloads.
Doc

Still crashes blender.

Damned! I’ve no Possibility to test the Script on OSX. And there are no Error-Messages on the Crash, right? I’ve no Idea why this happens.
Maybe it’s a Blender-Bug? I think i have to search for an OSX System fist, to do some testings.
Thanks for Help, mr_bomb. I’ll see what i can do.
Doc

if OSX is unix based there gotta be a debugger for it, like for linux if blender crash just open the debugger run blender and when it crashes it says way…

Ok, the 1.1 Update is out. It’s tested with 2.33a unter Win and Linux. I don’t know what’s on OSX. Look at the Header Topic for more Information.
Doc

I have been having problems when I try to export the model using the Unreal Static Mesh. It says that the Quads: 3150 - INVALID. Could someone please tell me what this means and the best way to fix this problem.

Thx

convert everything to triangles


this script can eat a surprizing amount of memory

blender has allocated 461828k at the moment, and I’m only trying to export a 252000 or so triangle mesh…
[tho, I guess that really isn’t that big of a concern, I can write a stupid export which uses like no memory if I care to do this frequently]
________________- edit 2 __________________
okay, so running this for 21 hours is long enough to determine I’m not patient enough to let it finnish.

system: athlon xp 2000+ (1.6 or 1.7Ghz)
1Gb ram
windows xp

mesh: 292928 triangles, 126802 verts
[suzanne subsurfed level 4 iirc then converted to triangles]
has vertex colors

memroy currently allocated by blender: 557676k
in examineOb()
is that called on every redraw?

Hello Guys
Do You relly use such large Meshes in Your Unreal-Levels? :o
The Script examines the Object each Time You reentering the Script-Window with the Mouse. And with large Meshes as Your’s, this can take a while.
But 21 Hours is tooooo much! I’ve never tested it with such giant Models. Maybe i should add a disable Option for this.

yeah, so that is the problem

it probably only took, say… maybe half an hour or some other time in which I wouldn’t keep the cursor in the window, so clicking the export button would never have an effect [because the script is busy]

had I understood that when I started it probably would have only taken an hour at most [that long because I would inevatibly mess up a few times]

a tell-tale sign the export function wasn’t working was that the file was never opened…

my intention wasn’t to use such a large mesh in an unreal level, but to try to bake the vertex colors into a texture on a low poly object

the obj format doesn’t support vertex colors and I don’t think there is a good .lwo export

so, ase is the option

I keep getting invalid texture message, what file formats are valid textures? how do I fix this problem?

I’ve got a monkey in my sights now. works great.

I was wondering if this can export animations (not armatures)
because I’m making a racing mod and I’m doing the vehicles and varia in blender. I figure armatures might be too much to wish for, but normal animation?