Unruly Shadows!

Hello,

I’m having an issue where the shadow from one object is appearing on the ground plane underneath an adjacent object when it should be obscured. It’s as if the shadow is ignoring the second object. Anybody have a fix?

Thanks!

Hi, we need a test file or at least a screenshot.
Impossible to help you without.
Please add system specs, Blender version too.
You have less than 10 post and cant attach, use http://www.pasteall.org/blend/

Cheers, mib

Thanks for the reply. I uploaded the test file to paseall.org. Link is below.

http://www.pasteall.org/blend/43189

If you toggle the shadow for the cylinder on and off you will see its shadow is visible underneath of the cube. Do you know how I can make the cube block the shadow?

I’m using Blender 2.77a on a Mac Pro Trashcan 12 Core.

Thanks!

First of all, you have Cube shadow turned off. In case the problem is in this point, go to object>ray visibility and fix that.
PS Again, in Shadows tooltip it’s said: “Object visibility for shadow rays”, that exactly explains your situation. Having turned it off, you make Cube Invisible for Cylinder (or whatever) shadow and it passes through the Cube as if it’s not in the scene, don’t you?

@blackcatt - I left the cube’s shadow turned off on purpose in order to help illustrate the problem.

So, there’s no way to have Cube’s shadow turned off and still have Cylinder’s shadow interact with it? Bummer. This is imperative for compositing when you don’t want unnecessary shadows in your scene. It becomes a masking nightmare. Hopefully this will come in a future build.

Thanks for the help blackcatt.

I’m not sure if this can/should be changed. The way I see it, there must be a (cylinder) shadow as the cylinder is blocking all the light. The light just can’t reach the space behind the cylinder - so it stays dark.


The additional cube cannot change this absence of light - with shadows activated or without.

But if you want no shadows behind the cube there should be better ways than masking this by hand. Maybe you could simply resize the bottom plane or apply a holdout shader to the invisible/shadowless parts.