Unsure about topology cleanup result & UV Unwrapping help?

Hello all!

I’ve tried modeling things in the past randomly but only a few days ago started seriously devoting my time to it.
I’ve watched many, many videos and followed tutorials from sites ranging from youtube, digital-tutors to blendercookie and picked up many helpful stuff. But I’m still quite unsure about a lot of stuff. Mainly about topology and getting UV’s to unwrap decently.

I’ve modeled a sword for my very first project after having drawn up the concepts in photoshop and ended up with this in Blender:

Which has worked out pretty well for me, but when I UV Unwrap it, this part in particular is quite a mess:

The UV looks like this:
(It seems I cannot attach more files, I’ll link to it instead) http://i.imgur.com/1pJn89H.png

I’m not sure if it’s good or looked down upon, but I included my source files (including the few older blender files showing my attempt at cleaning up the Topology)
I was wondering if anyone would have any input for me on this. I’ve cleaned up the Topology a bit but have no idea whether I have the right idea, what I could do to further improve, or things I can look out for to avoid anything I may have done wrong.

Thanks in advance!


source files.zip (739 KB)

1st thing to do when modelling is to check if your normals are correct, as normal can have influence on unwrap too.

While in Edit Mode, press N , scroll down to Display and enable “Backface Culling”

You’ll notice some faces seem to turn invisible in your model

That’s because they have inverted normals, so Blender think they’re pointing “inside”.
To fix this on your model, select all and press CTRL+N (or click on the “Recalculate” button in the toolshelf, to the left of the 3D View).

Now for the unwrap, the problem is always to find how to place seams to Blender know where to “cut” and create a nice non-distorted UV map.

But before anything, you need to fix the model.
By example go into face selection mode (either click on the button for it or press CTRL+TAB -> Face) and notice this black square, it means that there’s an edge thing that is very wrongly considered a face.

Go into Edge selection mode and select that Edge that is very wrong like this.

Press X -> Edge to delete it
Then remake the faces so it become correct

Check on the other side of the model , there’s a similar wrong edge there you must delete and rebuild the faces manually too.

Once done, notice this face :

It’s an ngon (face made of more than 4 vertices), in itself it’s not a problem, but ngon can be annoying during an unwrap, so i suggest making this ngon into triangles/quads
(you can select 2 vertices in that Ngon and press J to join them into an edge)

Now go into Edge mode and select those edges by example (they’re not necessarly the best choice, but in the end it works) and press CTRL+E -> Mark Seams

Now select the whole thing, press U -> Unwrap
Press F6 in the popup change the Method from Angle Based to Conformal (for this specific unwrap it will give a better result, but for other unwrap can end into Angle Based being better, usually when something is organic/rounded Angle Based is better, just try with both settings to see)


Oh man! This has worked flawlessly and thought me a few things in the process. I didn’t know at all about the Backface Culling checkbox.
Thank you so much!