Unwanted Flickering In Output [Video Inside]

Hi, thanks for reading. My name is Rachel & I’m using Blender 2.48. I’m having a problem where some textures and/or surfaces for some of my objects are showing a weird unwanted ‘flickering’ (for lack of a better term), in the final rendered output. It’s possibly related to shadows, since the intensity of the shadows seems to change frequently in an unnatural way. I don’t know.

Here’s the .avi I rendered with Blender’s internal renderer (3.04MB, approximately 13 seconds):

http://www.myotherdrive.com/dyn/file/012.180104.21082009.88974.6a65fi/lrf1.avi

And here are my render settings:
http://a.imagehost.org/0448/rendersettings1.jpg
http://a.imagehost.org/0605/rendersettings1_renderlayerspanel.jpg

Here are my Ambient Occlusion settings:
http://a.imagehost.org/0832/ambientocclusionsettings1.jpg

And lastly, here are the material settings for the objects most noticeably ‘flickering’ in the rendered video (this material is used for several sections of wall, all of which ‘flicker’ in the video at some point):
http://a.imagehost.org/0742/materialsettings1a.jpg
http://a.imagehost.org/0666/materialsettings1a_mapto_tab.jpg
http://a.imagehost.org/0701/materialsettings1_F6panel.jpg

Basically almost everything I do in Blender is just ‘guessing as I go’ - at best, I have a poor understanding of what it all really means & how it works. It would not surprise me if I have some unnecessary or incorrect settings here that are causing this ‘flickering’ problem.

I’m hopeful someone can point out what’s causing the problem. The .avi should be helpful in displaying the problem, anyway. [Edit: It’s clear I need to slow down and tweak the path, big time - as it is, it’s painful to the eyes - though unrelated to the flickering issue, hence my need for your help.]

Thanks in advance for your posts!

Rachel :slight_smile:

Hi,

Make sure you don’t have more than one face in the same place - it can cause flickering like that. Check to make sure you don’t have duplicate objects in the same place, and remove doubles to reduce the chance of overlapping faces within the wall objects.

If this doesn’t help, you could try posting the .blend file so we can take a look.

Thanks for the post, rawpigeon. However the wall objects are all very simple cubes with six faces each (4 sides, a top and a bottom). There are no doubles as far as vertices go. No extra faces either.

The objects are also not overlapping each other, they’re perfectly aligned yet separate.

As to the .blend, I would prefer not to post it because one, it would be freaking huge (like well over 100 MB) if I packed it. Two, the screencaps I gave in the first post with my rendering settings, ambient occlusion settings, and material settings - in conjunction with the rendered output AVI file - ought to tell the story, no?

Thanks in advance for your posts, I truly do appreciate them everyone hugs. Especially since I can’t proceed with any rendering until I figure this out - I’m just refreshing the subforum here over and over, waiting for a post in this thread. :slight_smile:

I noticed that you had ‘Normal Map’ selected for the wallpaper textures when they don’t seem to be Normal Maps. If ‘Nor’ is selected for the wallpaper material it might be producing weird results. I don’t know if it would account for the flickering though.

Dear Alakazam, thanks for your post. I just realized I had mistakenly posted the screencap of the F6 panel for the material twice. I’ve replaced one of them with the proper image now, i.e that of the F5 panel for the material in question. I don’t believe ‘Nor’ is selected, but please take a look at the images again. Thanks!

Are you using raytrace or buffer shadows? Try turning off the features gradually until it makes a difference: In the render tab turn off Rad, then Ray, then Shado then SS and Env. If turning off Ray makes a difference, try enabling it again and disabling the Ambient Occlusion in the World Settings Panel. Again, the general method is to turn off stuff until the problem disappears so you see what is causing the problems.

Edit: Also, always render to an image sequence, never an animation format. It’s just bad practice.

Hi,

Could you upload a reduced version of your .blend (e.g. containing just one flickering section of wall, the lights and camera)? I know this might not be possible (the problem might go away) but it would certainly help me. I can’t see any obvious problems with the information you’ve supplied so far, so the problem might be elsewhere. I’d like to check the geometry of the objects, the normals, the scaling of the object, any modifiers that are active, whether the faces are set smooth, the kinds of lights being used, the kinds of shadows being used, etc. Basically, anything that might affect the shading of a surface in a view-dependent manner.

Hi again rawpigeon hugs. OK here’s a reduced version of the blend with just the walls, floors, ceiling, light, camera, and path. Oh, I left the light switch on the far wall too. I packed the .blend so it should be good to go. It’s 3.51 MB.

http://www.myotherdrive.com/dyn/file/966.012523.21082009.34036.6a64fi/lrf1_simplified.blend

To Hoverkraft, yes I am using both raytracing and radiosity. When I try rendering without them, it looks awful and the lighting is all off - it significantly affects the way the ambient occlusion works in this scene. Previously transparent glass objects also end up looking solid when I do this. So yeah. No go on turning them both off (for now).

When I render with raytracing but without radiosity, things & shadows looks noticeably noisy and crappier than when I choose to turn radiosity on. Apparently radiosity is pretty necessary to my scene.

When I render with radiosity but without raytracing, it seems to make little if any difference from when they’re both turned on, so I figure may as well have them both on.

Lastly, I rendered to an .avi in this instance because the scene is by no means finished…I just wanted to see what it looked like so far taking the camera for a fly through. It showed me that I need to slow things down for path speed, amongst other things. Was just a test render for this work-in-progress.

But the flickering, blinking walls thing is something that definitely needs fixing…and since I have no idea what’s causing it, I’m here. hugs Many thanks to all of you for your time & kindly help. :slight_smile:

It’s not so much about what looks good but about what makes a difference eg if the flickering disappears with the shadows turned off you can turn them back on and know it has to do with the shadows and concentrate on finding the error there.

I had a similar problem myself and I read somewhere that turning autosmooth on would fix it, it did for me. I dont know how it works but in my case it did so you sould try that

Hi,

I’m not sure exactly what’s causing the problem but I’ve been able to do a quick render of your animation using some reduced settings (lower OSA, 50% size). Incidentally, I found it rendered faster with a lower Octree resolution (I used 64).

You have a raytrace lamp outside your room. It’s not doing anything (because the ceiling is in the way), so try removing it (or moving it to an unused layer). When I removed it, I didn’t see the kind of flickering you had before. I’m still not sure why this would cause flickering though, and I’m aware it might be my reduced settings that removed the issue.

First off, I have NO idea why you’re using multiple objects when you have the array modifier - that’s where your flickering is coming from - you have overlapping edges really close together and blender can’t tell which shows up more. It’s easier to just use 1 plane for the ceiling and one plane for the floor. if you’re going to use multiple objects, use the array modifier - it will make your life much simpler.

second, I see what you were trying to do with textures, so I helped you out a bit.
I uv-unwrapped everything, fixed the walls (I applied an array modifier)- you’re not going to see any flickering - and I also used the radiosity how it was supposed to be used: it’s supposed to be baked, not rendered on every single frame . the every-frame radiosity is if you’re rendering out a single frame or you are a person with a bunch of free rendering time.

I baked the radiosity for you- if you view textured mode, everything is textured in the viewport.
No AO, no major lighting (I think i turned ray tracing off too)
I also used some nodes so you can get a good grip on how they work.

Oh and here is some help with the radiosity baking:
http://vegastrike.sourceforge.net/wiki/HowTo:Radiosity_baking_in_Blender

  • you want to make sure your normals are flipped the right way too . otherwise you’ll get a black solid where your light should be.

here’s the .blend:
http://speedmodeling.org/smcfiles/amdbcg_helproom.blend
everything is textured, radiosity baked and good for animation.

also here’s a video output :

Be thankful for the help, I skipped physics homework for this :yes:.
oh yeah, and what is this supposed to be for, anyways?
-amdbcg

Attachments