Unwanted "texture" showing in textured viewport shading

Hello everybody,

I’ve got a problem which is affecting negatively the shading of my model with Cycles.
Basically, some kind of checkered pattern appears there. This pattern doesn’t seem to be the usual test one that can be set when doing UV unwrapping. Please note that I haven’t even attempted doing that, at least intentionally.

By setting the viewport shading mode to “textured” it’s apparent that portions of the 3d mesh have a different texture than others:


As you can see, the Cycles rendered view is also negatively affected:


What could be the reason of this?
How do I get rid of this texture, making the mesh surface look like the hood of this car?

As it shows up in the render the texture must be applied somehow. can you show us the node setup for the material?
I might be possible, that there are two surfaces or even two objects at the same position. Not that the headlight seems to be affected in the viewport shading, but not in the rendering.

There are no textures applied. The note setup for the material is the following. There are no texture nodes (just checked):


I might be possible, that there are two surfaces or even two objects at the same position. Not that the headlight seems to be affected in the viewport shading, but not in the rendering.
I even tried to delete a face, then recreate it, there weren’t hidden ones below. The new face inherited the problem.

Eventually (since some time passed since the time I posted) while looking for a solution I tried toggling the Weight Paint mode and I noticed that colors weren’t consistent between mesh portions. By making it completely in red (which I guess means max weight) the problem appears to have fixed.

However, I am still not sure what I have done. I’d like to reset those texture/weight settings to their default values in any case, but I’m not sure how.

JUst attach your blend file

Fortunately I found an old version of this file with the problem still showing:

corsab3d_02.zip (90.4 KB)

You didn’t include the environment texture so I had to use a different one. Try disabling the solidify modifier

Attachments



the issue is created by the solidify modifier, probably is a matter of a too dense mesh or a problem with normals.

Disabling the solidify modifier unexpectedly worked. I’m not very convinced on this solution, though. I don’t think this artifact is supposed to happen. Anyway, now I’m left with the mesh weightpainted in red (that was done in an attempt to solve this problem, which kind of did, since in a newer version of this file the solidify modifier is enabled without glitches). The default value is dark blue, right?

EDIT: I found out that the culprit is the vertex group to which the modifier is applied. Removing the vertex group from the modifier solves this problem, apparently. It looks like there are some bugs in how vertex group are affecting this modifier, as other problems occur when more of these modifiers affecting different parts of the mesh (through different vertex groups) are stacked in the modifier list.