Unwrap. UV Mapping is broken

I create dices. And i have ideal cube with dimples. When i use unwrap i have this result:
http://filebeam.com/5503c596ec8fcafb1dcc7fcf286a1242.jpg

I’m reading forum and found, what with “Conformal” i can fix my problem. So i changed “Angle Based” to “Conformal” and have this:
http://filebeam.com/64a8edafb27e6b8be7310834aa422dba.jpg

This much better, but not ideal. What i must do for ideal UV Mapping ?

Model in attach.

Attachments

dice5e5.blend (798 KB)

Agreed. Uv mapping tends to distort badly for some reason. No idea how to fix it…

Possible solution? You can select two opposing verts, scale to zero in the perpendicular axis, and pin them. The next step would be to unwrap again, causing the unwrap calculation to be ‘cleaner’ or more neatly arranged to your liking. Careful work of doing this can help set up a very good map.

I don’t expect the first unwrap to be all,end all - I expect it to make the first step before I manually arrange things to optimize my map. It is very close as it is, except for the angle of the map in relation to the window.

Forgive me if I am incorrect in this - wouldn’t:eyebrowlift2: be the first time.

What unwrapping method are you using? I would try unwrapping one side at a time using the ‘project from view’ method and then stitching the maps together how you want.

If you select just one face in edit mode of your dice and the press ‘Shift V’ and choose ‘To Selected Top’ the view will align perfectly to that side of the dice. Then just select all the faces making up that side of the dice and unwrap using ‘project from view’. You can then repeat this for the other sides.

I think u->unwrap (smart projections) could also improve the result. With the right settings.

With unwrap (smart projections) i set stretch to bounds options and have this:

http://filebeam.com/9187a2529ea2ad3988da900ffccfe75e.jpg

Very strange result, becouse seams selected correctly, I don’t know what do. If create UV Map face-by-face this not good solution for models like human body, with this i finish my UV Map after year :slight_smile:

Could you post a pic of your seams selection? It might be more accurate, i.e., you may have better right angles in the sides of the faces, if you make seams for the edges of all faces so they unwrap as separate units, then stitch them as needed.

For human forms, seam selection is critical, as it determines the best way to stitch some areas back together in the UV layout.

Yes, please:
http://filebeam.com/7502fff2076e2d0c42a1678036c429c7.jpg

Orange edges - is seams.

I can’t understand why peoples don’t examine my attached model and dont say what i do wrong.

Right now I have 2 instances of Blender going, one rendering an image that’s been cooking for about 6 hours now, and the other in which I’m editing a UV unwrap, plus Photoshop standing by with a 4K multi-layer image texture waiting to be painted on – if I open anything else my comp will prob’ly melt down :smiley: So please be patient. Many problems can be solved by just looking at screen caps, anyway. Your seams are set to unwrap the cube as a “t”-shaped flat, one island only. Try making seams that separate the faces into 6 islands, unwrapping, and then stitching things back into the “t” shape, you may get better right angles.

It does seem odd that it’s so hard to get the initial unwrap to be squared up, though. You may not be doing anything wrong.

I looked at your file, and I wonder if the method you’ve chosen to model your dimples with is causing the unwrap to be uneven - I looked closely and saw that your dimple is made with some very odd shaped pattern - I would suggest trying a UV Sphere cut in half or so to make your dimples - it might be more even and utilize the angle calculation better.

I noticed this because I tried to recreate the setup with a simple subdivided cube set to seams in a t shape, and had no problem getting the unwrap to be straight.

I suspect the hemispheres and skinny triangles are weighting the unwrapping calculations differently in the faces with 3 and 4 pips, causing your distortions. One fix might be to select the UV’s that should be straight, align them (eg, S-X-zero), pin them (P-key), and unwrap again. Do this separately for all the edges that should be aligned.

Edit: I just tried this on your file. It doesn’t take too long and it works well because the model’s essentially a cube.
Edit edit: I owe Craigomatic a coke. Sorry, I didn’t see you had already suggested this upthread.

well you don’t need to unwrap your dice to have colored dots. The dimples can just have there own black material.

You should follow Craig’O’Matic’s first piece of advice and scale two opposing verts to zero, pin them and unwrap again, or just grab a couple of the verts on the corners that are way out of place an move them so that the edges connected to those verts are straight pin them and unwrap again.

Can you paint how i must Pin vertecies, i’m not fully understand ?
Scale X or Y get me solid line, i can Pin her, but if i’l try change other vertecies - Pinned vertex is moved :slight_smile:

UV’s are “pinned” only from the point of view of the unwrapping code. The user can move pinned vertices all he or she wants. (This is very useful in Live Unwrapping of organic models). Pinning simply tells the unwrap algorithm “when you do the unwrap, keep these pinned UV coordinates where I want them.”

i’l try change other vertecies - Pinned vertex is moved

Is this causing problems? How are you “changing other vertices”?

  • I’m a select top vertecies with shift, and do Scale->Ykey->0->Pkey
  • then i go to bottom vertecies of “ankh” and select they, and do scale like for Top verts.
  • and i see what left from few Pinned vertex is moved to Right.

So i don’t understand why he’s moved if he pinned. I understand what left bottom corner and left top corner is one vertex on model, but Top pinned, not bottom, why pinned vertex move if i try change Bottom vertex scale. I’m expect what Blender just restrict scale for axis on this vertex and change only Y/X.

not sure I fully understand the situation you’re describing, but by any chance do you have Proportional Editing enabled? This could affect UVs unintentionally if its on and shouldn’t be.

Proportional Editiong don’t working what i expect.

I try all what you write, but this work only vertex by vertex arranged and few scale some places. Any ideas ? May be you write step by step if you solved this problem ?

I stoping learning blender before don’t sovle this problem.

This problem with UVs coming out warped is frustrating, I deal with it all the time. What I do is in the UV image editor under the UVs menu, enable “Live Unwrap Transform.” Then I pin verts at specific corners and move just those verts until things line up again.

In the case of your model, I pinned these verts:


And then I moved them until things were more evened up. I attached your blend file that I modified like this, so you can play with it.

Side note: I believe this problem occurs regardless of irregularity of geometry, location of seams, etc. I believe this happens with any fairly dense mesh, one with a lot of verts. You can see this with the default cube: in edit mode select all edges of the cube and mark them as seams, then unwrap - looks fine. Back in the 3D window subdivide the cube six times and unwrap again (may take a while) - now things start to look weird.

Maybe this is a problem with the unwrapping algos, like a precision problem? I don’t know, I’m not a coder.

Attachments

dice5e5_mod.blend (797 KB)

i’ tried to make a copy of the first file to try the different UV unwrap

so the first thing i did was to remove the UV existing
then change the location and cancel rotation on the dice
but when i save it and reload the dice is back to it’s old location

what i’m doing wrong here
how come i cannot change the location and rotation of this dice ?

Thanks