Unwrapped UVs warped, unsure how to fix

On several occasions I have had my UV map be warped in the sense of most of the islands will be transferred and seem perfect, but others that are “mirrored” will be disproportional and completely wrong. I have attached an Ambient Occlusion map that is extremely warped on one of the “wings” of my current project, it also has odd black areas that make no sense to me. I always begin modeling with a mirror modifier and only apply it after I have the model finished and all needed seams are marked, though I will say I have had to go back to editing this model once or twice. Any ideas on what I could be doing wrong?

Attachments


For unwrap problem, add seams to more appropriate edges
Try both Angle based and conformal unwrap methods. Some areas may be better with one than other areas of your unwrap. Change between the two in the toolshelf after you unwrap.
Remove internal faces
Remove double vertices (W / remove doubles)
Disable the mirror modifier for rendering when you bake
Ensure your face normals are pointing in the correct direction (recalculate with Ctrl+N)
If you bake AO see if disabling the normalise tickbox improves it so you don’t get the extreme black areas, you can get more contro, if you adjust curves externally

Thanks for the quick response. I’ve followed what you said, but unfortunately the UV map didn’t change at all. I will try the normalize tickbox disabling later for the black areas.

I have reviewed the seams in my model, and after adding a few seams the unwrapping looks much more organized and there is minuscule to no distortion. The black areas are still appearing, though. Is this perhaps because I am baking the AO map while the model is in an animation? By which I mean I have posed the model, and that it is affecting the appearance of the AO due to the stretching and contracting of the faces of the model?