Unwrapping a lightsaber (beginner)

I’m very new to 3D modelling and have been following some tutorials.

I can’t get my lightsaber to unwrap. In the tutorial, the unwrapping looks very organized and flat, but when I do it it’s just a big mess.


I’ve remade the model from scratch 5 times now, and I just don’t understand what I’m doing wrong.

I would appreciate some help.

Thank you in advance.

PS. I don’t know what more info I should give to make it easier to find the problem, so please tell me if there is anything more I should add.

You need to create ‘Edge Seams’ before unwraping.

A sugestion, try to imagine you’re trying to build your model with paper… where would you cut it and glue it?
In Edit mode, select the edges that you want to split in the UVmap, and CTRL+E > ‘Mark Seam’.

Then unwrap again.

But the thing is. The guy in the tutorial marks only 1 seam for the whole thing (except a few for the square box).

Whilst I can’t even get only the base (the stick itself, not the square box or the small bumps on the bottom) to unwrap without distortion.


That’s how he gets it, and that is with the square box and the little bumps on the bottom.

And this is me without the square box and the bumps, only a cylinder with some extrusion.


He is using Cylinder projection if that is of any importance.

Thank you!

I figured it out!

It had nothing to do with seams and stuff. It was just a setting on the left side when you unwrapped. Called directions. Default was on “view on equator” but changing that to “Align to object” made it work.

Hi kablash,

I am doing the same tutorial and I am stuck at the same step. I just registered here to see if you could help me.
When I select my mesh after having made the seams and try to unwrap nothing happens. At all.
The UV wrapping window stays empty except for the grid. I have tried to the same unwrapping by making another cylinder real quick with some cuts and that happens. That suggests that it my lightsaber mesh. I have one little flaw in my lightsaber mesh which is visible in the screenshot. But the seam is there and I think it should still work. However, unwrapping does nothing at all. I have tried your “Align to object” tip. It is really annoying because you can’t skip this step at all.