Unwrapping aspect ratio problem

Hi all :slight_smile:

After some years of use of non equal to 1 aspect ratio when unwrapping a mesh on an non square texture, yesterday i fell off my chair !!!
I unwrapped a mesh on a 4096x512 texture and the unwrap had an aspect ratio of 1 !!!
:open_mouth:

At first i thought this problem was for the worst a bug or at least a choice from developpers but now i know it’s a parameter !

lemme explain:

here’s what i use to have when unwrapping a mesh on non square texture:


Here we see clearly the unwrap is 4 times higher than it should be. 4:1 is my texture aspect ratio. I just have to select all UVs the S and 0.25 and it’s okay.
When using a square texture, UVs have a 1:1 aspect ratio.

now look at this:

Even if we don’t see clearly the UVs ( as the texture is tall ) we can clearly see they are unwrapped in a 1:1 aspect ratio !!!
:open_mouth:

WTF am i missing ???

where is that parameter that defines UVs aspect ratio on the texture ???

I bet this is a damn simple checkbox somewhere :wink:

ah and… all my meshes have a scale of 1:1:1

Any idea is really welcome !

thanks and happy blending !

EDIT: i have to mention that the mesh of the second pic was first mapped on a square texture ! the i changed the texture to a 8:1 aspect ratio texture, and re-unwrapped it.
maybe it has something to do with UVs aspect ratio ? maybe Blender still takes the 1st texture aspect ratio ? i got no idea :confused:

BUMP ^^

nobody knows a solution on this ?
or even knows about this problem ??? :open_mouth:

check the operator panel after unwrapping

the operator panel ?

sorry :confused: i’m not sure. Do you mean the one where you choose conformal/angle based, etc?
and where there’s an inefficient ‘correct aspect’ toggle ?

Yes. Correct aspect there

for me it’s just a ‘do nothing at all’ toggle :confused:

ticked or unticked, whatever are the other unwrap parameters, it changes absolutely nothing tu UVs.

I wish it would ^^

Do you have any other idea JA12 ?
Maybe i should upload a blend so that you can play with it ?

ok… it appears noone is aware of this problem/bug… i won’t gu further… i just do ‘with it’…

i haven’t time to waste for this.
too bad, but it’s ‘like this’ :slight_smile:

happy blending anyway ^^