Unwrapping thingy?


I have a little problem… When I want to save a UV Face Layout I get this error message: “Python script error: check console” :confused:

What do I do to make it work? Before I only had to re-unwrap it but that doesn’t work now…

All help appreciated

Whatever you do don’t look at that console; there might be an error message there!


Well, it actually pops up when I hit the export button… So nothing happens

The Console is the black, DOS-type window that runs behind Blender. In Mac or Linux it may not be there by default and you would need to open it from Applications/utils or somesuch. The little message you’re seeing says to check that console where the reason for your script futting will be written. Check the thread below for an updated script and see if that solves your problem:



Um… How do I update, edit or create a new script? I am not that familiar with scripts…

I think you just find the script you need, download it and place it in your blender scripts directory.

Well, when I download it I only get a normal text, no file or python file. Does that mean I have to “make” a new script?

Drag or use Select All to Copy that text (and ONLY that text) and Paste it into Notepad. At the bottom select “All Files” and save it as YourScriptName.py. When you add the .py (instead of .txt) it will be saved as a Python file.


Unfortunately I din’t get it work:(

Thanx for all the help


Were you in Object Mode and did you have your object selected before you tried to run the script? I’m making assumptions about which scritpt you are trying to run, however, you can help yourself by providing more details. :slight_smile:


Hi MikeCuffe,

Well, when I try to unwrap it I am in the UV Face select mode and I have selected it, then in the other window (Uv/Image editor) I select all the vertecies (I think that is what they are called, and som of them are pinned) and then in the “save uv face layout…” I hit the export button. That is where the error message pops up “Python script error: check console”. If you have any idea on how to fix this please tell me. :o
I tried to use the script that Fligh % directed me to, but that didnt help… :frowning:

Sorry, couldn’t answer before today because I have been on a holiday

“Python script error: check console”.

So what does the console say the error is?


Console error:

Traceback (most recent call):
File “(string)”, line 136, in bevent
IndexError: list index out of range

List index out of range usually means the Object is not selected, in this case probably that you are not in UVFace mode or that your Vertex Groups (if you have them) are not selected in Edit mode while in UVFace mode.


Unfortunately I have everything selevted in Uv face and Edit mode and in the Uv window… and that didn’t work with all things selected or unselected:(

Could you goto File >> Pack Data, then set everything to the point just before you press the Export button and save it? Then upload that blend here:


Post the link to that file here and I’ll look at it.


I have uploaded it now, hope this link works:o :


Your file’s UV layout exported fine for me in 2.41 with the updated exporter script. Question: When you run the Save UV Face Layout script, do you get a small popup window inside the UV editor with a vertical OK button on the right? Or does one of your existing windows change to the UI for the script? This will tell us whether you are running the updated version (popup window).

To update your script, follow the link in the thread fligh % gave you above, click Download, and save UV_export.py to your scripts folder. It should be in the folder where Blender is installed, although this varies with OS. Then open a Scripts Window in Blender and go Scripts Menu->Update Menus. Now you should be able to run the script from the UV editor.

If it still doesn’t work tell us what Blender version you are using and what OS, and try to post a screenshot of the errors.

Thank you guys for all your help! :smiley:

It worked now, didn’t know I had to update the script menues, and I used the wrong web browser :o It couldnt download the script as a file, Internett Explorer beta something has got some problems with downloading files and viewing web pages:mad:, don’t use it… (to download files)