UPBGE Logic nodes

So, i’ve been using UPBGE with Logic nodes, and as soon as i finished my controller i exported the game engine as runtime and opened it… but i guess that Logic brick not working after exporting

actually, the video how it should work:

I answered over on Discord as well:

The runtime exporter has an option to copy Logic Nodes requirements over to the runtime, but if that doesn’t work you just need to go to your .blend file, look for the “bgelogic” folder next to it and copy that over to your .exe :slight_smile:
It’s just missing the node-generated code, that’s all

Thank you forbyour solution!

oh,wait, there seems to not be an option to copy logic nodes, and after i copy “bgelogic” folder to my .exe file Logic nodes seems still not to work. Maybe you can send a video, that can help me to help me figure out where i can find and run this option?

Aaaah I just noticed, you’re using 0.2.5
the nodes are quite outdated there sadly, I need to try that for myself quickly


Alright, it should work if you compile your trees, then copy the bgelogic folder next to your .exe like that :thinking: that’s what worked for me

aaaah… “if you compile your trees”? Maybe I don’t understand something, because I cant see this option :-/

the button’s called “Update Code” in 0.2.5

nope, it doesn’t work

what you can try is opening up a terminal (just click on the windows button and type in “cmd”) and navigate to your .exe using

cd "path_to_your_file"
if you’re on a different drive than C: you just need to type e: for example to access the E: drive first

and then start the exe by doing


then you should see error messages when closing the game, maybe you can tell me what it writes there

this is a weird issue that shouldn’t be happening

oh, wait, now my game runs correctly… Thank you!