UPBGE 'Mouse Over' blocked by camera in Use Viewport Render mode

Well the title says it all. I can’t get anything to respond to a Mouse Over event. When I run in Standalone mode, it works fine. I tweaked everything I could think of but no luck.
This is version .30

edit: actually to be specific, the Mouser Over doesn’t work when the view is through the camera. When I break away from the camera-view then it doesn’t block mouser-overs anymore.

Can you print the hitObject.name?

It returns “Camera”?

Mouse Over sensors works for me with Use Viewport Render in UPBGE 0.34.

Can you try .30? I don’t want to development on an alpha release.

I don’t actually get any kind of response to the camera object when the view is through the camera AND playing in Blenders viewport (see my edit, I forgot to hit the send button)

Here it works for me
UPBGE_0.3_mouseover_viewport.blend (812.7 KB)

I don’t want to develop on an alpha. Can somebody try this on .30?

?? I created it in 0.30

@shadowphile despite the misleading terms of UPBGE 0.3+ experimental builds being labeled “alpha”, they’re actually more stable than UPBGE 0.3.0, which has a lot of bugs that have since been fixed. I highly suggest you try one of the recent builds and see if that solves your issue.

If you’re still unsure, please share a blend.

@RPaladin, Good to know, thanks!
@ all…took me forever going back and forth but I figured out the problem. My camera was panoramic, which isn’t surprising since EEVEE and Workbench don’t support that mode. It needs to be culled from options in the BGE. (I’m porting a panoramic point-in-click project into BGE so used to using a panoramic camera).
Thanks for the working demo, don’t know WHEN I would have figured this out!

1 Like