[updated july 15 2019] Eevee real object based Motion Blur v0.4

I also did some tests, but without any useful result.
It’s best to do a bug report and wait to see if it’s fixed or if you can get some additional information about the save_render() method.

1 Like

Can’t seem to get this addon to work at all - I installed from the zip, and I can confirm it’s in the AppData/Roaming/Blender Foundation\Blender\2.80\scripts\addons folder, but not showing when I search for the plugin in order to enable it.

build is 2019-07-10 23:46 (New splash screen)

Any idea?

Uncompress the zip and install just the .py file

1 Like

That seems to have done the trick, cheers!

1 Like

There’s a new barely noticeable update: 0.4.
Most changes are under the hood: code cleanup, some functions are optimized, should perform faster and overall the code is neater.
Main change is in the technique used for the subframe rendering itself, that now uses real subframes instead of the time rescaling hack I used before. I wasn’t able to make it work that way before, so the need for the hack, now I’ve realized what was the silly mistake I was making, so it’s fixed :wink:
The only visible improvement is that –if you manage to– cancel the render, your timeline isn’t screwed up anymore.
And the script gives a neater console output too.
In time i’ll fix everything I can.

1 Like

Many thanks g3ntile.

1 Like

Thank you! You’re awesome!

1 Like

BADASS.
Thanks to you, Eevee now is U N S T O P P A B L E

1 Like

Small bugfix. 0.4.1 is available now.
0.4 introduced a bug in the shutter speed calculation for adaptive sampling. Now it should work ok.
Thank you all!

Guys, I would love nothing more than to have the time to read this entire thread, but sadly I don’t… So is this bad-boy able to produce total moblur (non camera) in EEVEE, with great aplomb?.. I see things like badass and unstoppable above… and I’m pretty excited, but Is there any downside or limitations? I have three 980Ti Hybrids, so rendering is pretty fast for me in E-Cycles, even with moblur… but if certain things can be rendered in EEVEE in almost real-time with multiple GPUs, that would rock, fo sho. Please advise.

This outputs real motion blur via eevee to rendered image sequences in about 1/5 of the time cycles does. Test it and see for yourself.
With very few caveats: a slight color difference with F12 we couldn’t solve.
No 3D viewport preview and the image doesn’t show in the Render Image window. Apart from that it works. I’m using it in production.
Keep in mind that this is a workaround, if you see something wrong, tell me and we’ll try to fix it.
[ Edit: oh, and no cancel either… I know. I couldn’t make it work, if you know how just tell me ]

Hey thanks!.. But I can’t get Forced EEVEE Motion Blur to even show up in EEVEE settings… Does this not work (not available in menu) if I have an E-Cycles version of Blender running (but switched over to EEVEE, obviously)? I can’t even find the addon in Prefs… :-/ Please help. I am eager to do a quick test!

You have to download it from the link above in the post, unzip it and install it from the preferences, like any addon, but selecting just the uncompressed eevee_motion_blur.py file, not the whole .zip
Then enable the addon by ticking the checkmark to the left of the addon.
You will find it in the render settings, usually at the bottom, you can rearrage it later as you like.

D’oh! I had it in the folder that it came in. I dragged that folder from zip into my addons folder… which I believe I have with other addons, with no probs… anyhoo, I see it now. Off to test! Thanks again!

Edit: Double-D’oh! Black output! My PNG in my output folder is black… I have HDR bg lighting and even added a point light for good measure. Renders great in E-C (lit well, moblur fine…), switch over to EEVEE and click Render Motion Blur Frame button, check image in output… black…

Edit #2: Tried EXR and that is black as well… Just testing with cube moving in front of plane, both different colors… Again, E-C render is dope, ForceMB render is dud… :-/ I even cranked render in PS to see if this was a gamma issue etc… there is no image data there…

1 Like

@g3ntile I tried the add on after you added the adaptive settings and everything works well. The only issue I have is that it doesn’t add motion blur to my cloth physics which I have parented to my meshes.

I hope to see this feature added sometime in the future.

Great job, this is a big help in getting a complete and quick overview of my animations before I render in Cycles.

1 Like

I did all sort of tests with physics and it always worked… here is a quick cloth test, it worked ok for me. You have to bake them first –that’s recommended before every animation render anyway–

Maybe your’s is some special case that somehow breaks it, if there’s no problem send me the file so I can study the case, or describe better your setup.


Keep in mind that the adaptive thingy uses the bounding box of the mesh –for speed– so effects that don’t change the bounding box of the mesh –particles, animated textures, certain movements occuring inside the bounding box will not add to the movement detector. To account for that cases you have the minimum samples option.
Cloth physics usually change the bounding box a lot, so there shuould be no problem with that.

Mr. g3ntile sir, can you look again above at my last post (edited after you read it). I’m just getting black output, no matter what I do…

Are you using the Compositor?
This workaround relies on a Viewer node –because the python API doesn’t have access to the Render Node–. If there’s no Viewer node it creates one connected to the same socket that the Renderer. But if there’s already a Viewer node, the system takes it’s input untouched, to bring the fexibility to motion blur any point of the Compositor tree and don’t break anything.
Besides that, chech if your gamma is not set accidentally to zero or something like that (usually should be 0.454545).

[EDIT: silly question, but regular eevee renders ok? –F12 I mean– to be shure it’s not some incompatibility with eevee… ]

I think I have it working, in the Compositor, which until this point I had not used, because I do all my comps is PS and Fusion… I’ll report back if I have any more difficulties. Thanks again!

Oh, and yes everything rendered great in E-Cycles.

Thanks for your testing!
I have a question: but you had something non-standard in the Compositor right?
The addon expects either no Compositor tweaking at all, in which case it builds the needed tree, or that there’s a tree with no Viewer node –same case as before, the viewer node is automatically added– or that the existing Viewer node, if any, takes some input. In that case, THAT input will be rendered. Tell me if that was your case –just to debug–