Updated to latest build - previously hidden objects now permanently hidden

(etufoz) #1

Hi everyone,

Ran into a weird issue in a project I was working on. I have all my objects in various collections, some were turned on and some off. Now in the latest build, I assume because of the changes that were made to the outliner, the collections that were turned off now have all contents permanently greyed out as if they’ve been hidden even though the visibility icon is on.

I only realised this after making some progress in my work and although I have previous saves in the older version of 2.8, I’d like to figure out how to recover my hidden objects.

Any ideas or workarounds would be greatly appreciated.

Kind regards,
Ed

(Dalai Felinto) #2

Hi, could you please report it in: https://developer.blender.org ?
Without a sample file to reproduce the problem is really hard to track down these issues.

(animelix) #3

in the outliner is a filter-option, there are the settings for disabling rendering and linking/unlinking the objects. (restriction toggles)
i think you have unlinked your objects by pressing alt-click, this works different now

1 Like
(etufoz) #5

aHHHH, thank you!! Yes, the visibility toggle was off by default in this build, so I just turned it on and could then toggle visibility for the objects that were hidden. Thanks again.

(English is not my native language) #6

Anyway, download the latest 2.8 build. I think @dfelinto corrected the problem yesterday for that kind of .blend files saved with old 2.8 build.

Edit:
Last night I had build blender and in outliner it appeared “Globally disable in viewport” by default, so problems in this kind of old files were solved:
untitled.blend (698.9 KB)

I just built blender 2.8, and again Temporarily Hiden in Viewport is the default column. So you should do what @animelix recommended to you anyway.

(Mr_Flamey) #7

I had some issue yesterday with collection visibility and thought it was a bug, but later realised it was just poor shortcut assignments.

Pressing the number keys in edit mode changes element selection type
Pressing the number keys in object mode instantly hides different collections with no indication as to what just happened or how to undo it. It seems to be linked to the old layer behaviour in 2.79 and collections made invisible this way can’t be made visible through the outliner, only by pressing various combinations of numbers and the shift key. It’s horrible and I’m not sure if it’s a bug or a feature, but I hope it either gets removed or made very clear what the hell is happening.

Press 1 - Hide all collections EXCEPT the first in the outliner
Press Shift + 1 - Toggle visibility of the first collection in the outliner

This is really confusing, especially if the first collection is empty. You can see icons in the outliner change, but changing the visibility back IN THE OUTLINER seems to be impossible. It feels like some weird relic of the layer system, and layers visibility being toggled with number keys seems like insanity now we have named collections. Maybe it’s just some strange bug with the shortcut or preferences?

(etufoz) #8

The keyboard shortcuts for Collection visibility seems out of context in 2.8 especially seeing as there are no visible numbers assigned to Collections in the Outliner. I removed at least number 1-3 as you use those in edit mode to switch between component modes. I think shortcuts shouldn’t affect collections as there’s too much room for user errors.