Urgent! softbody + curve need to be fixed ASAP

Hey guys,

need your help.
I’m using softbody on curves, so far so good.
But for some weird reason that I’ve not yet figured out, the median point on the curve gets a odd angle.
Also, sometimes it seems the wind affect just the first 100-200 frames and no more: may it’s due to the position of the Softbody modifier in the panel stack?

Any quick hint/help will be much appreciated! :slight_smile:


wire-test.blend (153 KB)

Bezier curves are a bit problematic with soft bodies, because the auto alignment of the tangent handles is no longer working. Instead the handles are pulled to the next control point. However a curve with 3 control points may look nice but is very unlikely to give a realistic rope / wire simulation.

So i would suggest to subdivide the curve at least twice.
(You will need to remove the old hook and set a new one.
Also found that vertex parenting works better here. )
For even better results you might try to convert the curve to a nurbs.
When i do things like that i always start with a bezier because they are easier to edit (IMHO) and convert to nurbs to have nicer physics.

The “only works a few frames” effect is most likely due to caching / bake / settings.

Thanks for the help bjornmose,

unfortunately converting to nurbs doesn’t fix the problem, neither adding more subdivision: also this way I’ve more points to set the weight and it’s painful how in Blender often you can’t select multiple points / object and assign value to all of them.

It’s a shame that there’s this weird behavior with the curves: every time I’m in production and want to use Blender, I get always weird results with curves or difficult situation to handle. I know, the more you know the software the more you can use it, but hoped this time to have the chance to use it since I love the softbody in Blender.

P.S. I’m quite sure I’m doing something wrong in my file, still haven’t figured out what though…

Oh, you need to make the nurbs uniform U to be smooth.
wire-smoothnurb.blend (155 KB)
And when setting weight to curves W_KEY is your friend.

Hey Bjornmose,

you’ve been very helpful!
Thank you a lot for the nurbs hint, it worked pretty well. Btw, I’m still using a few points on the curve and it works fine as well :wink:

If it is realistic enough for you. You are the artist!

“A good horse never jumps higher than needed” (German proverb)