USB Flash Memory Troubles

I got one of those nifty USB flash memory sticks, but I’m having some trouble. I just want to move files from one of my XP boxes to the other, but now one, and only one, of my computers, won’t talk to it. It shows the files in the browser window, but if I try to copy it it tells me it can’t read the file. I tried copying a file onto it on the uncooperative computer, and that didn’t work either. If I bring it back to the other computer it works fine though. Also, the first day I had it it worked perfectly well with the other computer.

A friend of mine who’s a computer consultant said maybe it was a problem with permissions. I sure don’t know. Do you have any ideas?

Have you checked the log in the root folder?

Mine says this:

Checking file system on E:
The type of the file system is FAT.

One of your disks needs to be checked for consistency. You
may cancel the disk check, but it is strongly recommended
that you continue.
Windows will now check the disk.
Volume Serial Number is 3069-2EAC
Windows has checked the file system and found no problem.

130531328 bytes total disk space.
   225280 bytes in 5 hidden files.
   124928 bytes in 60 folders.
110800896 bytes in 295 files.
 19380224 bytes available on disk.

     2048 bytes in each allocation unit.
    63736 total allocation units on disk.
     9463 allocation units available on disk.

Not sure if yours will tell you anything, but maybe it will give you a clue. (or maybe yours doesn’t have a boot log)