Useful accidental discovery!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Whenever the “use blender materials” is enabled in the game menu, you may be disappointed to find that no UV mapped texture is being displayed on the objects which have a UV mapped texture on them as well as a material attached to them. A skybox simply becomes useless at that point. But, you can clearly notice that the objects that have a UV mapped texture on them but no material look really nicely shaded when you
enable the “use blender materials”. You do really want such shading to appear on your objects as well as UV mapped textures be visible on objects having a material, don’t you??
So here’s the plan:

  1. Turn on the “Texface” button in the material buttons.
  2. Add an new texture channel, a blender texture channel and set the texture to “None”.
  3. For a skybox, you may turn on the “Shadeless” button, change the basic colour in the material buttons and add some “emit” to it.
    CHECK IT OUT YOURSELF!!!

Thank you.
I guess that you get the same effect enabling “Light” In Face Select mode?!

One warning, blender materials can slow down big levels.

lol ive known that for quite a while :wink:
but good idea posting it :smiley:

Congratulations! You’ve successfully learned to abuse the “!” character… LOL…

if your not seeing your blender material using your UV’s… then you need to tell your texture to use those UV in the UV options in the materials tabs. I think it defaults to Orco or something… infact you can even set the UV to be moved by an empty and do some simple texture animation

chinu3d, please restrain yourself and try to use no more than one punctuation mark per title. Thanks.