Useing Alpha Channel....

Hi,
my problem is about using alpha channel. Its in the picture below.

Q: how to make GOOD on one picture? :slight_smile:

What ive done:

  1. Make a bottle made with glas
  2. Used picture with alpha channel to make texture transparent
  3. Became disappointed… :slight_smile:

I would be grateful for any help…

S

Attachments


…and id like to add sth more about pictures:
In picture 1. i set up FRESNEL factor on 1
In picture 2. i set up FRESNEL factor on 1,46

You need to set your label texture to adjust the alpha of your material. Right now, it only affects the color.

Enable the “Alpha” button in the “Map To” panel.

Attachments


im sorry. Its not working for me… i mean im not able to solve the problem still.
Once again (mybe i wasnt to precise):

I want to make label NOT transparent and transparent bottle only…

…now the label is as same transparent as bottle…
How to chane it? and make label not transparent…

S

I think what you are looking for is an alpha mask. to make one simply make a black and white image where your label is white and everything you want to be transparent black. then set the texture to alpha.

I’m sorry too. When you said:
“2. Used picture with alpha channel to make texture transparent”

I thought you were saying that your picture already had an alpha mask. Afalldorf is right; you need a black-and-white mask to tell the material which part of the label should be opaque.

Yes, my picture had alpha mask…
What i did is:

  1. Cut the mesch and put on it my texture (.JPG) by placeing it in UV editor.
  2. Then i load a txtur (.TGA). Its a same picture + alpha channel in the file with B&W mask there…

should it work like that?

I think you misunderstand… Although it is possible to use an alpha channel in a tga it is much more complicated. An alpha mask is basically a separate file that is a copy of your alpha channel. The alpa mask actually contains no alpha data just black and white pixels so it can be any format, png, jpg, or whatever.

In the Map Image panel of your Texture Buttons, make sure that the “Use Alpha” button is enabled. If you don’t, then the alpha channel information from your texture will not be passed on to the material.

Fweeb is right… i forgot about that:spin:
I guess I was thinking of another program is used to use…
Of course if you still can’t figure that out then the alpha mask will work as well.

OK! im almost there!.. now i just cant force the white places (from alpha channel) in my render to show the colored places…
is there sth what should i just press?

First. which method did you use? alpha mask or alpha channel? (I know confusing:rolleyes:)
It sounds like you used the alpha mask and forgot to turn off color for the mask texture.
Just a guess.

A screen shot might help…

ok. Sorry for my lack of information… ill try to do better.

So…useing alpha CHANEL

  1. It works! I make black places invisible (THANKS A LOT)… but the problem is still the same :frowning: …

Problem:

  • when i have label with alpha mask on my bottle (looks good) then im makeing the bottle “from glass” (Mirror Transp > Ray Transp > …) and the label is from glass TOO… why?
  • in a fact it is a simple question: How to make beer bottle with label of your project?

Always grateful for any help…

S

Ohh I did not realize you were using raytracing… I don’t think blender has the ability to control fresnel of raytrans with a texture. I think your best option would be to create a plane that has the label texture on it and wrap it around the bottle much like a real label.

Someone correct me if I’m wrong about fresnel mapping…

EDIT: Just a thought… This seems like a good place to use the new shrinkwrap modifier.

This is so interesting, because I have been having EXACTLY the same problem, with EXACTLY the same model. I created a beer bottle, made it the right color, and made it transparent using the raytracing method. Then, I tried to apply an image map of a beer bottle label (a png, which has an alpha channel of its own), and it too appears to be transparent. I monkeyed around with a number of settings, and it always appears transparent. Apparently, an image map inherits the properties of whatever it is mapped on to. This is a major shortcoming, if true. I think afalldorf has the right idea, or work-around. Make an object that is located on the bottle, very thin, in the location where the image map should be, and map the label to it.

Oh. Wow. I had no idea that’s what you wanted.

You’re going to want to use material nodes.

Make a beer bottle material that is glass, set up your alpha, fresnel, whatever. Set this material to use nodes.

Then, make a label model that has your texture, is not transparent or reflective, etc.

Then, go back to the bottle material, and go into the Node editor. Make sure you’re working on material nodes, and not composite nodes.

/uploads/default/original/3X/2/c/2c07ef08465150217aa8c70d8bf1aa5be1884f9a.PNGstc=1&d=1226634980

Then, you’re going to want to set up your nodes like so:

By using the texture as a mix factor, you tell the label material to only show up where the texture has alpha. Otherwise, the glass bottle material should show through. I just tested this with a procedural texture, since I didn’t have an image handy, and it worked well. There might be another step for an image texture, but try it this way first.

The material node editor is powerful, and it sounds like it’ll be getting even more powerful with the next version of Blender. Specifically, it allows you to use multiple materials to set options that can only have one setting, like fresnel. It’s a good idea to play around with it and see what kinds of effects you can create.

Attachments



YES! almost there!
…the only thing i cant solve now is: How to direct texture?

  • im not able to do it in UVeditor (i dont know how to connect cuted mesh to “glass” mesh)
  • it works when i let blender to stretch texture on mesh by its defoult settings (i mean when im not doing anything)

so… What to do to be able to direct texture from “texture cube” to “glass cube” (i was practiseing on cubes :slight_smile:

Sorry… don’t know what you mean by “direct” the texture.

Are you saying the texture doesn’t show up when you set the mapping coordinates to UV? You have to unwrap the mesh first. If you’re working with cubes now, don’t use UV mapping just to practice. If your bottle is UV mapped, it should be fine. Otherwise, use whatever mapping you already have set up.

You shouldn’t need more than one cube to practice. This is going to be one material assigned to your beer bottle, with one more material referenced through the node editor.

Or am I way off again? I’m sorry I don’t know what you’re talking about. Maybe try to describe the problem in more detail?

ok
the picture below is an effect of your post with nodes (THANKS A LOT for that). I was trying to do it as same as its possible for me.

The next question is: How to put label on the other cube’s wall (or anywhere else)?

I’ve done nothing to palce this texture on cube. Blender do it by itself. I just by putted this texture in…

Attachments


YES! YES! YES!
ive done it. Thanks to all of you here… and especially to TheGryphonRider. He made a huge job for me… Thank You!

Below is the “final” render… yes, i know… its not perfect :slight_smile:

Take care all of You.

S

Attachments