Using Alpha for Object Transparency.

I’m making the move from Maya to Blender and trying to understand some basic concepts that I can’t seem to get answered in Docs.

For instance, I’ve imported a 3DS tree model which has pine needles. The import seemed to include the structure of a basic painted texture, and a separate alpha to make the entire polygon it’s mapped to is transparent, except for the needle cluster.

Yet when I render, I get the full polygon. I’m including an image of the map and the separate alpha, and shows the final result I’m looking for. Also including the BLEND file.

I would appreciate the help, and also would be interested in finding someone I could hire here and there to set up some scenes. Using Blender 2.55 Beta, Mac OS on a MBP.

Kind regards, and look forward to your response.


I guess what you need to do is check Z Transparency in material options (somewhere). And enable alpha for the Texture. Also, you should not use alpha masks, it’s better to have transparent .png or .tga.

Hi farufon,

here is a blend file with the material you need :slight_smile:

I hope this will help you!


pine_alpa.blend (722 KB)

This is very kind, thank you!

Here is a simple example of a file I’m trying to fix, ie: do as you suggest. I’ve even included the transparent png.

This simple example would certainly point me ahead.

Thank you kindly.

PS. Attached is png. The .blend file has to be downloaded above, since upload to forum was sketchy.


POVTree.blend (3.39 MB)