using bake normal map how to ?

i applied a normal map to a plane

but if i set the spec value of the mat to almost 0 then i cannot see the normal map
independant of the NOR value for the Normal in texture panel!

this is with the second wood texture image
cause i can render the normal map with no problems!

is this normal ?

or did i forget to set something else ?

thanks for any help

I don’t know if this will fix your problem, but in the Textures panel under the Image Sampling tab, I would make sure that the ‘Normal Map’ check box is checked.

Hope this helps!

normal is already set

it looks like it’s the second wood textuer image that introduce the problem
but not certain how to correct it

as i said i can render only the first normal texture map and it looks ok
but when i add the second texture then i’m loosing the first one ( normal map ) function of the Spec value of the mat !


In order to see a normalmap you need specularity and shadows obviously that’s how the whole perception of the world through your eyes works :smiley:
To see it in viewport you need a lamptype that supports shadows in viewport, and/or specularity. Quite easy.
How do you expect to differentiate bumps from the flat surface if it doesn’t has either specularity or is casting shadows?

let me show the 2 images

1 - spec = 0.1 or almost 0

2 - spec = 0.5

so as i reduce the SPEC value even the normal map seems to go away

so your saying that if you use only diffuse you cannot get any normal map!

is it samething with bump or height map ?


just did a test on an alpha map or bump map and it is not affected with spec value

but i woudl prefer the normal map with bake for cycles
hope it becomes available soon!


It seems you fail to understand the basics of a normal map.

A normal map, manipulates the normal vector for lighting for a point.
How do you perceive bumps on something in real life?
You see highlights (specularity) and dark areas (shadow).

If you use a plane with a texture and apply a normalmap:
Turn off specularity and crank up emit -> Normalmap is gone.
Turn specularity back up -> You can spot the Normalmap again because you see the highlights.
Turn off specularity again and turn off emit -> You can spot the Normalmap again because you can see the shadows.

And exactly the same will go for a bumpmap.

If something casts no shadow you can’t tell if a feature is impressed or embossed it just looks flat, same goes for highlights.