Using Blender 64 in the Program Files folder


I’m using Vista 64bit as my operating system and I have my software installed in the program files folder and my data located within the documents folder.

How can I use Blender x64 so that I can place it within the program files folder but also allow me to use the “save default settings” command? If I place the blender folder within the program files folder and use the save default settings command I get a “Failed writing defaults” error because blender doesn’t have permission to write to the b.blend file.

I suppose the answer to this is to copy the blender program files into the program files folder and the .blender folder into the document folder. But if I do this how do I tell blender where the .blender folder is? Or maybe there is a better way to do this?


to be able to save in the program files folder, you need to run blender as administrator. Right click on the icon and select “run as administrator” (assuming you are the admin)

I am the administrator. What i’m after though is to get it to work like the installer version of Blender. Where you need to be the admin to install but after that everyone can use it even if they are not an admin.

When you use the installer blender installs to the program files folder but all config files go to the application data folder (I think). How do I tell the x64 version of Blender, which doesn’t have an installer, to work like this?


Maybe you could try this:

Open the registry editor while being logged in as admin.
Go to “HKEY_LOCAL_MACHINE\SOFTWARE\BlenderFoundation”.
First, backup this key (“Registry” > “Export Registry File”, or something like that).
In the right pane, open “Home_Dir” and clear its contents.

Go to “x:\Program Files\Blender Foundation” and remove any .b or similar files/directories (again, copy these somewhere safe, just in case).

Now, Blender should search for and try to open settings from “Program Files” and failing to do that, it should look for them in the current user’s “%AppData%”.

If this doesn’t work and you want to restore everything you modified, just double-click the registry file you saved, and restore from backup the files and directories you removed from “Program Files”.

Hope this helps.

Thanks ManOfSteel, i’ll give this a try and report back. Hopefully one day we’ll get an installer for the 64bit version of blender.

Finally found time to try this but soon realised this isn’t going to work. There is no installer for the x64 version of Blender so therefore there is HKEY_LOCAL_MACHINE\SOFTWARE\BlenderFoundation in the registry because no installer has put it there.

So i’m still not able to save my settings in Blender because I don’t have write access to the Program Files folder. There must be a way to do it because the 32bit installer allows you to run Blender from the Program Files folder and allows you to save your default setting.

Just copy the Blender folder to Public Folder.

I’d like it to work like the 32bit version of Blender and every other bit of software I have installed on the computer and put the Blender folder within the Program Files folder.

Any other ideas?

You could try installing the 32bit installer version and then downloading the 64bit zip and replacing the 32bit files with the ones in the zip file.

Works for me :slight_smile:

Hey metalliandy i’ve just your suggestion of installing the 32bit version and then replacing the files 32bit files with the 64bit files but i’m getting a “The application has failed to start because its side-by-side configuration is incorrect. Please see the application log for more detail.” error.

This is what I did.

Download and install the 32bit installer and installed Blender in the program files folder.

The I downloaded the 64 bit zip file I copied the complete contents of the zip file, apaprt from the plugins and .blender folder, into the program files folder replacing any existing files.

Then I copied the plugins and .blender folder into the C:\users\me\AppData\Roaming\Blender Foundation\Blender folder replacing the existing folders.

Is this what you did?

I wonder if the problem is related to the fact that the contents of the 64bit zip file didn’t match exactly with the files that were installed using the 32bit installer, so some files were not replaced in the program files folder because no equivalent existed in the zip file.

Just thought i’d uninstall the 64bit version into its own folder and try and run it and I get the same error message about side-by-side configuration is incorrect so it looks like there is a problem with the 64bit zip file.

Anyone know how I can fix this error?

Hey reck,

I installed the 32 bit so the scripts folder was in the Blender folder and then just copied everything over from the 64bit zip and allowed the folders to be overwritten when needed.

Im not sure about the error you get though…


I am getting the same error message. Basically i have installer version of blender, now i’m trying to run the 64-bit version(but of course it doesn’t install in to the computer, because supposedly its a zip file), and when i’m trying to open Blender i’m getting the same error message. Pleas can anyone tell me what that is? Or how to make it work. Thanx

Pleas help. I’m getting side by side error, what can i do. I have tried everything you guys just said, but none of them work. I’m installing Visual C++2008 (x64), but that wont install, it says “the version of this file is not compatible with the version of Windows you’re running.” Why? i have 64-bit version of Vista, why can’t it install. Pleas pleas help.

Thank you thank you very much. So far i’ve been able to solve all those problems, of course i still have to install Luxrender. But can you pleas tell me how do i install Python 2.6 in Blender. Coz when i open the program, that black screen behind it was unable to find the python, even though i have it in my computer. Can you tell me. Thanx.

Can you guys tell me, is it a good idea to overwrite Blenders python script with downloaded new version python script?